aboutsummaryrefslogtreecommitdiffstats
path: root/community/stunnel
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-14 00:20:57 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-14 00:21:23 +0100
commit5313cdd34d58f3730e9a55f36124b1e524b3c818 (patch)
tree1042b7426d280022dc3bcf645b136e1f36e241ed /community/stunnel
parentd527c9fe284e8b4fa427c93583ccd9884ca2df72 (diff)
downloadaports-5313cdd34d58f3730e9a55f36124b1e524b3c818.tar.bz2
aports-5313cdd34d58f3730e9a55f36124b1e524b3c818.tar.xz
community/stunnel: upgrade to 5.43
Diffstat (limited to 'community/stunnel')
-rw-r--r--community/stunnel/APKBUILD16
-rw-r--r--community/stunnel/stunnel-libressl.patch11
2 files changed, 19 insertions, 8 deletions
diff --git a/community/stunnel/APKBUILD b/community/stunnel/APKBUILD
index 6f54c0c2a0..84bf293c01 100644
--- a/community/stunnel/APKBUILD
+++ b/community/stunnel/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=stunnel
-pkgver=5.42
-pkgrel=1
+pkgver=5.43
+pkgrel=0
pkgdesc="SSL encryption wrapper between network client and server."
url="http://www.stunnel.org/"
arch="all"
@@ -38,18 +38,18 @@ check() {
package() {
cd "$builddir"
+
make DESTDIR="$pkgdir" install
- install -Dm755 "$srcdir"/stunnel.initd \
- "$pkgdir"/etc/init.d/stunnel
- install -m644 "$srcdir"/stunnel.conf \
- "$pkgdir"/etc/stunnel/stunnel.conf
+
+ install -Dm755 "$srcdir"/stunnel.initd "$pkgdir"/etc/init.d/stunnel
+ install -m644 "$srcdir"/stunnel.conf "$pkgdir"/etc/stunnel/stunnel.conf
mkdir -p "$pkgdir"/usr/share/doc/$pkgname/examples/
mv "$pkgdir"/etc/stunnel/stunnel.conf-sample \
"$pkgdir"/usr/share/doc/$pkgname/examples/
}
-sha512sums="875af19e8a4fa8e983e98d3e6bea198b789bea9b18933ed74aa1f9ce6922e4c4dd3a4ccae3b74c12de30c39b68c3210c9adb7cd228c7fefc28dff258dcdb4968 stunnel-5.42.tar.gz
-43bb220856b6f1ce04a5f30f7482c135043310962867ac4b7e5505f2347dd3c205738ea3a72a48dfa71f040060c3c1080ef06dd15053122ba720053bb49cdd6c stunnel-libressl.patch
+sha512sums="3158ab7573d8c548ee71aecb3f94e141bd80e123a62848945263004e28668050a8a08c904dbf61df28c4f5c1d94eb380943ab39835ccd18273a6acf05a3488a8 stunnel-5.43.tar.gz
+63d24daa59fb7416929915a8d17f8dda21f1702f5a2f11cb45d6ac0d91478fa892805b209fa7e181ec5910b1c5cad8c06d11c05d15868f7f7da46d87a05a5820 stunnel-libressl.patch
33e215413e08fdd5783cc76e6ba6a2342fb6d0573f801815c4d3022625e71be6c9739d47a7a61bf7c803f27911b9c92cf6ae3e522add040f83802e1aaeaee000 stunnel.initd
a72bfddeb74787d58c9fd24782d86c0498ce3530a43fbdd4ec4c4b57baa6257b6ef21005aca274b22c4a22cdbbbcee63dd3d841f458af248db9c69e8d59fa56f stunnel.conf"
diff --git a/community/stunnel/stunnel-libressl.patch b/community/stunnel/stunnel-libressl.patch
index c4f6dda772..84dc83e3c3 100644
--- a/community/stunnel/stunnel-libressl.patch
+++ b/community/stunnel/stunnel-libressl.patch
@@ -89,3 +89,14 @@ Index: src/verify.c
#define X509_STORE_CTX_get1_certs X509_STORE_get1_certs
#endif
/* modern API allows retrieving multiple matching certificates */
+--- a/src/options.c
++++ b/src/options.c
+@@ -3656,7 +3656,7 @@
+ }
+ #endif
+ /* engines can add new algorithms */
+-#if OPENSSL_VERSION_NUMBER>=0x10100000L
++#if OPENSSL_VERSION_NUMBER>=0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ OPENSSL_init_crypto(OPENSSL_INIT_ADD_ALL_CIPHERS|
+ OPENSSL_INIT_ADD_ALL_DIGESTS, NULL);
+ #else