aboutsummaryrefslogtreecommitdiffstats
path: root/community/stunnel
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-18 08:59:51 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-18 08:59:51 +0000
commitc82aee54167683571b5d7386b2f23d376ec1632c (patch)
treea8239316495204c2ab3131fe543216ceadf15209 /community/stunnel
parent66e6dfb84d1b32ea360f8086581002005418ab7d (diff)
downloadaports-c82aee54167683571b5d7386b2f23d376ec1632c.tar.bz2
aports-c82aee54167683571b5d7386b2f23d376ec1632c.tar.xz
community/stunnel: upgrade to 5.36
Diffstat (limited to 'community/stunnel')
-rw-r--r--community/stunnel/APKBUILD18
-rw-r--r--community/stunnel/stunnel-libressl.patch33
2 files changed, 39 insertions, 12 deletions
diff --git a/community/stunnel/APKBUILD b/community/stunnel/APKBUILD
index 1e64d3b022..a1e79657a8 100644
--- a/community/stunnel/APKBUILD
+++ b/community/stunnel/APKBUILD
@@ -3,8 +3,8 @@
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=stunnel
-pkgver=5.35
-pkgrel=3
+pkgver=5.36
+pkgrel=0
pkgdesc="SSL encryption wrapper between network client and server."
url="http://www.stunnel.org/"
arch="all"
@@ -13,7 +13,7 @@ depends=""
makedepends="libressl-dev"
subpackages="$pkgname-doc"
install="$pkgname.pre-install"
-source="https://www.stunnel.org/downloads/$pkgname-$pkgver.tar.gz
+source="http://www.stunnel.org/downloads/archive/${pkgver%.*}.x/stunnel-$pkgver.tar.gz
stunnel-libressl.patch
stunnel.initd
stunnel.conf"
@@ -48,15 +48,15 @@ package() {
"$pkgdir"/usr/share/doc/$pkgname/examples/
}
-md5sums="9079f5fafbccaf88b7d92b227d78249a stunnel-5.35.tar.gz
-ee6cd228bb9628336624e2261f3032b5 stunnel-libressl.patch
+md5sums="b3c002c312e757d9a40caf95363800b3 stunnel-5.36.tar.gz
+35509eaaee3f0c6a56d5ec16cf0588bc stunnel-libressl.patch
da32978d82c03158d7b947e10b1ba284 stunnel.initd
f1227c57d136eb7db3853844f683916a stunnel.conf"
-sha256sums="ffa386ae4c825f35f35157c285e7402a6d58779ad8c3822f74a9d355b54aba1d stunnel-5.35.tar.gz
-05df599689d23175ab9450ecc3a73a181e9ac2d9e3800d66e758fe5f0b51bc32 stunnel-libressl.patch
+sha256sums="eb8952fcfdfcdf5056a1f1a78e1ec5014b819c5f5f7599b924dc4490ffe4b5ea stunnel-5.36.tar.gz
+faf9e52e13008b6dc1c62e34871c30e885358c4684a166ceaf287960f975daf4 stunnel-libressl.patch
01c7c7f43cebb299659cd344a98bc64418d516f6530d0b24772d70bb1d56847e stunnel.initd
42971d32e5e79490564d2f71d6a47bbe4aaabd740ba75b75e38207ea0845fec1 stunnel.conf"
-sha512sums="cdec7ddafbfac4a1d420704baec72fedbd655871137ec8283c066203c0859019c6e11ce00647e5b471a019409e4eb5e9525166eddd7ddffa25055b95c0cacd9e stunnel-5.35.tar.gz
-42d180aeca48ea5d154f7561445ab7d7bb13598e859f914b71bba8ebf439ed02e0693798aad2b6cf3236844a5da1984bc74fd3827f7639b1e9da48c8589795ee stunnel-libressl.patch
+sha512sums="663dd155aab17b628fd1ef8ae1c604efc0cdf026566e98fbff16ba4da5b12b06cd6801bf4f604a9b2ea98d993c184ce97c63c1f716fa86b5e630e5fd504e3317 stunnel-5.36.tar.gz
+e80afff73159b9b702d5cce9d38325829f09018a349f69678a02828d64b5f054ea216b2011d1dff6a76076947daa60f1a5b26f3ca9747ebb10c730b3c78d1d21 stunnel-libressl.patch
33e215413e08fdd5783cc76e6ba6a2342fb6d0573f801815c4d3022625e71be6c9739d47a7a61bf7c803f27911b9c92cf6ae3e522add040f83802e1aaeaee000 stunnel.initd
a72bfddeb74787d58c9fd24782d86c0498ce3530a43fbdd4ec4c4b57baa6257b6ef21005aca274b22c4a22cdbbbcee63dd3d841f458af248db9c69e8d59fa56f stunnel.conf"
diff --git a/community/stunnel/stunnel-libressl.patch b/community/stunnel/stunnel-libressl.patch
index 9b39720c9f..16134e283f 100644
--- a/community/stunnel/stunnel-libressl.patch
+++ b/community/stunnel/stunnel-libressl.patch
@@ -34,7 +34,7 @@ index 5b282e9..7984f32 100644
NAME_LIST *curr;
char *cmd, *param;
diff --git a/src/options.c b/src/options.c
-index 22e00dd..5674284 100644
+index 6727226..d1bae90 100644
--- a/src/options.c
+++ b/src/options.c
@@ -1291,7 +1291,7 @@ NOEXPORT char *parse_service_option(CMD cmd, SERVICE_OPTIONS *section,
@@ -103,10 +103,19 @@ index 182c764..d57aff2 100644
#define CRYPTO_THREAD_write_unlock(type) CRYPTO_THREAD_unlock(type)
#else
diff --git a/src/ssl.c b/src/ssl.c
-index d5b27bd..8dae820 100644
+index ba30d75..29c423d 100644
--- a/src/ssl.c
+++ b/src/ssl.c
-@@ -78,7 +78,7 @@ int ssl_init(void) { /* init SSL before parsing configuration file */
+@@ -50,7 +50,7 @@ NOEXPORT int add_rand_file(GLOBAL_OPTIONS *, const char *);
+ int index_cli, index_opt, index_redirect, index_addr;
+
+ int ssl_init(void) { /* init SSL before parsing configuration file */
+-#if OPENSSL_VERSION_NUMBER>=0x10100000L
++#if OPENSSL_VERSION_NUMBER>=0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ OPENSSL_init_ssl(OPENSSL_INIT_LOAD_SSL_STRINGS |
+ OPENSSL_INIT_LOAD_CRYPTO_STRINGS, NULL);
+ #else
+@@ -83,7 +83,7 @@ int ssl_init(void) { /* init SSL before parsing configuration file */
}
#ifndef OPENSSL_NO_DH
@@ -115,6 +124,24 @@ index d5b27bd..8dae820 100644
/* this is needed for dhparam.c generated with OpenSSL >= 1.1.0
* to be linked against the older versions */
int DH_set0_pqg(DH *dh, BIGNUM *p, BIGNUM *q, BIGNUM *g) {
+@@ -118,7 +118,7 @@ int ssl_configure(GLOBAL_OPTIONS *global) { /* configure global SSL settings */
+ if(FIPS_mode()!=global->option.fips) {
+ RAND_set_rand_method(NULL); /* reset RAND methods */
+ if(!FIPS_mode_set(global->option.fips)) {
+-#if OPENSSL_VERSION_NUMBER>=0x10100000L
++#if OPENSSL_VERSION_NUMBER>=0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ OPENSSL_init_crypto(OPENSSL_INIT_LOAD_CRYPTO_STRINGS, NULL);
+ #else
+ ERR_load_crypto_strings();
+@@ -177,7 +177,7 @@ NOEXPORT int compression_init(GLOBAL_OPTIONS *global) {
+ if(global->compression==COMP_ZLIB) {
+ /* 224 - within the private range (193 to 255) */
+ COMP_METHOD *meth=COMP_zlib();
+-#if OPENSSL_VERSION_NUMBER>=0x10100000L
++#if OPENSSL_VERSION_NUMBER>=0x10100000L && !defined(LIBRESSL_VERSION_NUMBER)
+ if(!meth || COMP_get_type(meth)==NID_undef) {
+ #else
+ if(!meth || meth->type==NID_undef) {
diff --git a/src/sthreads.c b/src/sthreads.c
index 4e4e0e9..f61f230 100644
--- a/src/sthreads.c