aboutsummaryrefslogtreecommitdiffstats
path: root/community/sway
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2017-11-11 14:11:41 -0500
committerDaniel Sabogal <dsabogalcc@gmail.com>2017-11-14 13:58:26 -0500
commit4461f8f2c707fa42386f0f08259122f3d4f8ff1d (patch)
tree86f4fc818aa6b4c70d714ef13403f753212f8ea2 /community/sway
parent7884113f6a48c8452e6fdef5337bab4ef75315bc (diff)
downloadaports-4461f8f2c707fa42386f0f08259122f3d4f8ff1d.tar.bz2
aports-4461f8f2c707fa42386f0f08259122f3d4f8ff1d.tar.xz
testing/wlc,sway: unmaintained
Diffstat (limited to 'community/sway')
-rw-r--r--community/sway/APKBUILD49
-rw-r--r--community/sway/stdint.patch10
2 files changed, 0 insertions, 59 deletions
diff --git a/community/sway/APKBUILD b/community/sway/APKBUILD
deleted file mode 100644
index 8c05b0451c..0000000000
--- a/community/sway/APKBUILD
+++ /dev/null
@@ -1,49 +0,0 @@
-# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
-pkgname=sway
-pkgver=0.13.0
-pkgrel=0
-pkgdesc="i3 compatible window manager for Wayland"
-url="http://swaywm.org"
-arch="all"
-license="MIT"
-options="suid !check"
-depends=""
-makedepends="asciidoc cmake gdk-pixbuf-dev json-c-dev libcap-dev libinput-dev
- linux-pam-dev pango-dev wayland-dev wlc-dev"
-subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/SirCmpwn/$pkgname/archive/$pkgver.tar.gz
- stdint.patch"
-builddir="$srcdir/$pkgname-$pkgver"
-
-prepare() {
- default_prepare || return 1
-
- cd "$builddir"
- sed -i 's/login/base-auth/g' swaylock/pam/swaylock
-}
-
-build() {
- cd "$builddir"
- cmake . \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_SYSCONFDIR=/etc \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DVERSION="$pkgver" \
- || return 1
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR="$pkgdir/" install || return 1
-
- chmod u+s "$pkgdir"/usr/bin/sway || return 1
-
- local i; for i in 1 5 7; do
- install -Dm644 bin/*.$i \
- "$pkgdir"/usr/share/man/man$i/ || return 1
- done
-}
-
-sha512sums="7f137e103bb278777ee3e36b40446156ee02bfbba3ce099b23b093751832a67155cd9519f7583364608d584d2d7c9206a8945f2114ae58220b47bd0f1ff362e8 sway-0.13.0.tar.gz
-4967a6b1552a47be1ee978e2d9c590fc3748670fb321afb8c7a6134bc0cb237b5b98ce00f777e02ac6029265c690910a1688a0f56ff2f3125bd663f9444b737c stdint.patch"
diff --git a/community/sway/stdint.patch b/community/sway/stdint.patch
deleted file mode 100644
index 5c72680d45..0000000000
--- a/community/sway/stdint.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- sway-0.13.0/wayland/pango.c.orig
-+++ sway-0.13.0/wayland/pango.c
-@@ -4,6 +4,7 @@
- #include <stdlib.h>
- #include <string.h>
- #include <stdio.h>
-+#include <stdint.h>
- #include <stdbool.h>
- #include "log.h"
-