aboutsummaryrefslogtreecommitdiffstats
path: root/community/sway
diff options
context:
space:
mode:
authorDaniel Sabogal <dsabogalcc@gmail.com>2017-05-10 18:26:08 -0400
committerDaniel Sabogal <dsabogalcc@gmail.com>2017-05-10 18:28:35 -0400
commitcda6ff3a72917ed7ab183520c40401a006eea995 (patch)
tree71c2e68859226de4356edb7aed0918f7fe5fed6e /community/sway
parented197e16dd875d34554167c35ff82efba118d311 (diff)
downloadaports-cda6ff3a72917ed7ab183520c40401a006eea995.tar.bz2
aports-cda6ff3a72917ed7ab183520c40401a006eea995.tar.xz
community/sway: upgrade to 0.13.0
fix makedepends
Diffstat (limited to 'community/sway')
-rw-r--r--community/sway/APKBUILD11
-rw-r--r--community/sway/stdint.patch10
2 files changed, 17 insertions, 4 deletions
diff --git a/community/sway/APKBUILD b/community/sway/APKBUILD
index 4fe8874f59..8c05b0451c 100644
--- a/community/sway/APKBUILD
+++ b/community/sway/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Daniel Sabogal <dsabogalcc@gmail.com>
pkgname=sway
-pkgver=0.12.2
+pkgver=0.13.0
pkgrel=0
pkgdesc="i3 compatible window manager for Wayland"
url="http://swaywm.org"
@@ -8,10 +8,11 @@ arch="all"
license="MIT"
options="suid !check"
depends=""
-makedepends="asciidoc cmake gdk-pixbuf json-c-dev libcap-dev libinput-dev
+makedepends="asciidoc cmake gdk-pixbuf-dev json-c-dev libcap-dev libinput-dev
linux-pam-dev pango-dev wayland-dev wlc-dev"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/SirCmpwn/$pkgname/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/SirCmpwn/$pkgname/archive/$pkgver.tar.gz
+ stdint.patch"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
@@ -27,6 +28,7 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_SYSCONFDIR=/etc \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DVERSION="$pkgver" \
|| return 1
make
}
@@ -43,4 +45,5 @@ package() {
done
}
-sha512sums="dee93cc8e42e00589529ae413206593f2b1c67076aa6a27980f65ee7ad86ca80684e3cbbdad8c1cbd0741af7235364453257b855a5c722fc80fbad32a37dc4d4 sway-0.12.2.tar.gz"
+sha512sums="7f137e103bb278777ee3e36b40446156ee02bfbba3ce099b23b093751832a67155cd9519f7583364608d584d2d7c9206a8945f2114ae58220b47bd0f1ff362e8 sway-0.13.0.tar.gz
+4967a6b1552a47be1ee978e2d9c590fc3748670fb321afb8c7a6134bc0cb237b5b98ce00f777e02ac6029265c690910a1688a0f56ff2f3125bd663f9444b737c stdint.patch"
diff --git a/community/sway/stdint.patch b/community/sway/stdint.patch
new file mode 100644
index 0000000000..5c72680d45
--- /dev/null
+++ b/community/sway/stdint.patch
@@ -0,0 +1,10 @@
+--- sway-0.13.0/wayland/pango.c.orig
++++ sway-0.13.0/wayland/pango.c
+@@ -4,6 +4,7 @@
+ #include <stdlib.h>
+ #include <string.h>
+ #include <stdio.h>
++#include <stdint.h>
+ #include <stdbool.h>
+ #include "log.h"
+