aboutsummaryrefslogtreecommitdiffstats
path: root/community/swaybg/APKBUILD
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-02-27 18:42:21 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-27 19:12:05 -0300
commit5531839281da6cbbd0157ab1b521ee11ab0be86e (patch)
tree3106219e853eed56be4a70714de485e6a7ac365e /community/swaybg/APKBUILD
parentd354e779f2f93b9f4cbf23de8bedc5d0bf04a3ab (diff)
downloadaports-5531839281da6cbbd0157ab1b521ee11ab0be86e.tar.bz2
aports-5531839281da6cbbd0157ab1b521ee11ab0be86e.tar.xz
community/sway{,bg,idle,lock}: update url to use https
Diffstat (limited to 'community/swaybg/APKBUILD')
-rw-r--r--community/swaybg/APKBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/community/swaybg/APKBUILD b/community/swaybg/APKBUILD
index d5b23aeccf..e3eeefb541 100644
--- a/community/swaybg/APKBUILD
+++ b/community/swaybg/APKBUILD
@@ -2,12 +2,12 @@
# Maintainer: Drew DeVault <sir@cmpwn.com>
pkgname=swaybg
pkgver=1.0
-pkgrel=0
+pkgrel=1
pkgdesc="Wallpaper daemon for Wayland"
-url="http://swaywm.org"
+url="https://swaywm.org"
arch="all"
license="MIT"
-options="!check"
+options="!check" # no test suite
makedepends="cairo-dev
gdk-pixbuf-dev
libxkbcommon-dev
@@ -18,17 +18,14 @@ makedepends="cairo-dev
wayland-protocols
"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/swaywm/swaybg/archive/$pkgver.tar.gz"
build() {
- cd "$builddir"
meson -Dswaybg-version="$pkgver" --prefix /usr build
ninja -C build
}
package() {
- cd "$builddir"
DESTDIR="$pkgdir" ninja -C build install
}