aboutsummaryrefslogtreecommitdiffstats
path: root/community/taskd
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-03-17 00:46:05 +0100
committerMichał Polański <michal@polanski.me>2020-03-17 01:13:15 +0100
commitcefa5b1803f623483eea8ff186a1b11e0216603d (patch)
tree376e4fd56a847e8b03ff03e60f7c0f03741c1f87 /community/taskd
parentd03a7869634b5ace8541380635daf34b747a8e5e (diff)
downloadaports-cefa5b1803f623483eea8ff186a1b11e0216603d.tar.bz2
aports-cefa5b1803f623483eea8ff186a1b11e0216603d.tar.xz
community/taskd: move from main
Diffstat (limited to 'community/taskd')
-rw-r--r--community/taskd/APKBUILD47
-rw-r--r--community/taskd/Directory.cpp.patch10
-rw-r--r--community/taskd/Path.cpp.patch18
-rw-r--r--community/taskd/taskd.initd12
-rw-r--r--community/taskd/taskd.pre-install7
5 files changed, 94 insertions, 0 deletions
diff --git a/community/taskd/APKBUILD b/community/taskd/APKBUILD
new file mode 100644
index 0000000000..cfe7abef4f
--- /dev/null
+++ b/community/taskd/APKBUILD
@@ -0,0 +1,47 @@
+# Contributor: ScrumpyJack <scrumpyjack@st.ilet.to>
+# Contributor: Ivan Tham <pickfire@riseup.net
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=taskd
+pkgver=1.1.0
+pkgrel=7
+pkgdesc="Taskserver synchronises taskwarrior across multiple clients"
+url="https://taskwarrior.org"
+arch="all"
+license="MIT"
+depends="bash"
+depends_dev="gnutls-dev util-linux-dev"
+makedepends="$depends_dev cmake"
+pkgusers="taskd"
+pkggroups="taskd"
+install="$pkgname.pre-install"
+subpackages="$pkgname-doc $pkgname-pki::noarch $pkgname-openrc"
+source="https://taskwarrior.org/download/taskd-$pkgver.tar.gz
+ Path.cpp.patch
+ Directory.cpp.patch
+ taskd.initd
+ "
+
+build() {
+ cmake -B build . \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None
+ make -C build
+}
+
+package() {
+ make -C build DESTDIR="$pkgdir" install
+ install -dm700 -o taskd -g taskd "$pkgdir"/var/lib/$pkgname
+ install -Dm755 "$srcdir"/taskd.initd "$pkgdir"/etc/init.d/$pkgname
+}
+
+pki() {
+ pkgdesc="Tools for taskd PKI management"
+ depends="taskd gnutls-utils"
+ mkdir -p "$subpkgdir"/usr/share/taskd
+ mv "$builddir/pki" "$subpkgdir"/usr/share/taskd
+}
+
+sha512sums="df2349c354258fd1b014b1a9c78f68dc10c9e5a48357e282e8a760cf4e4aaf4d36486796ad094ee2b050e7506195b778e3316c90ef543a2f8242de313daa13aa taskd-1.1.0.tar.gz
+51f9a384c3c76c2719f8dbc378fad0717b02e508dcf3d08fcabf2ebed002501bb7760723d49ee210f15ac65b077c35ea765c22ea8793ead04141bc6f6b2c8b3a Path.cpp.patch
+fa3c8bec063119e7a8321a1be26e3c16ae1d1cbb34aa06becc29830f1e78180514a68981d9fd4c34b63755ab9afa2c5a295efeeea6dbce263bdf9c010d7c28aa Directory.cpp.patch
+c120566bd8e33de3980a554d62f6156f0650656985d108e2c577508b5f94f1040e4b70dc52f82210f1a5aeb9492a61c54a8d6c063ed6a999a3de4562426c36c1 taskd.initd"
diff --git a/community/taskd/Directory.cpp.patch b/community/taskd/Directory.cpp.patch
new file mode 100644
index 0000000000..4c53a08bff
--- /dev/null
+++ b/community/taskd/Directory.cpp.patch
@@ -0,0 +1,10 @@
+--- taskd-1.0.0/src/Directory.cpp
++++ taskd-1.0.0/src/Directory.cpp.changed
+@@ -34,6 +34,7 @@
+ #include <errno.h>
+ #include <stdlib.h>
+ #include <Directory.h>
++#include <limits.h>
+
+ #ifdef SOLARIS
+ #include <limits.h>
diff --git a/community/taskd/Path.cpp.patch b/community/taskd/Path.cpp.patch
new file mode 100644
index 0000000000..018a2029ee
--- /dev/null
+++ b/community/taskd/Path.cpp.patch
@@ -0,0 +1,18 @@
+--- taskd-1.0.0/src/Path.cpp
++++ taskd-1.0.0/src/Path.cpp.changed
+@@ -37,6 +37,15 @@
+ #include <Directory.h>
+ #include <Path.h>
+
++/* fixes build with musl libc */
++#ifndef GLOB_TILDE
++#define GLOB_TILDE 0
++#endif
++
++#ifndef GLOB_BRACE
++#define GLOB_BRACE 0
++#endif
++
+ ////////////////////////////////////////////////////////////////////////////////
+ std::ostream& operator<< (std::ostream& out, const Path& path)
+ {
diff --git a/community/taskd/taskd.initd b/community/taskd/taskd.initd
new file mode 100644
index 0000000000..cbf86f9a6e
--- /dev/null
+++ b/community/taskd/taskd.initd
@@ -0,0 +1,12 @@
+#!/sbin/openrc-run
+
+description="Secure server providing multi-user, multi-client access to task data"
+command=/usr/bin/taskd
+command_args="server --data /var/lib/taskd"
+
+start_stop_daemon_args="--user taskd:taskd"
+
+depend() {
+ need net
+ after firewall
+}
diff --git a/community/taskd/taskd.pre-install b/community/taskd/taskd.pre-install
new file mode 100644
index 0000000000..847ccc36d6
--- /dev/null
+++ b/community/taskd/taskd.pre-install
@@ -0,0 +1,7 @@
+#!/bin/sh
+
+addgroup -S taskd 2>/dev/null
+adduser -S -D -h /var/lib/taskd -s /sbin/nologin -G taskd -g taskd taskd 2>/dev/null
+
+exit 0
+