aboutsummaryrefslogtreecommitdiffstats
path: root/community/tcsh
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2020-01-25 04:01:07 +0100
committerMilan P. Stanić <mps@arvanta.net>2020-01-25 04:01:07 +0100
commit159a17e60debbce446df4ffdc4009355b40c8c27 (patch)
treebc14b7204b6d879004b49200031a57b35c94f4ab /community/tcsh
parent31b16cd38cf3db105e703d71298e1dbb1e0ee635 (diff)
downloadaports-159a17e60debbce446df4ffdc4009355b40c8c27.tar.bz2
aports-159a17e60debbce446df4ffdc4009355b40c8c27.tar.xz
community/tcsh: add csh to /etc/shells
fixes: #11164
Diffstat (limited to 'community/tcsh')
-rw-r--r--community/tcsh/APKBUILD2
-rw-r--r--community/tcsh/tcsh.post-install1
-rw-r--r--community/tcsh/tcsh.pre-deinstall1
3 files changed, 3 insertions, 1 deletions
diff --git a/community/tcsh/APKBUILD b/community/tcsh/APKBUILD
index 564f7ba179..f38c8b47f8 100644
--- a/community/tcsh/APKBUILD
+++ b/community/tcsh/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Dan Theisen <djt@hxx.in>
pkgname=tcsh
pkgver=6.22.02
-pkgrel=0
+pkgrel=1
pkgdesc="extended C-shell"
url="https://github.com/tcsh-org/tcsh"
arch="all"
diff --git a/community/tcsh/tcsh.post-install b/community/tcsh/tcsh.post-install
index 7342c5e721..33c7ebeba6 100644
--- a/community/tcsh/tcsh.post-install
+++ b/community/tcsh/tcsh.post-install
@@ -1,3 +1,4 @@
#!/bin/sh
add-shell '/bin/tcsh'
+add-shell '/bin/csh'
exit 0
diff --git a/community/tcsh/tcsh.pre-deinstall b/community/tcsh/tcsh.pre-deinstall
index 9e2e34c1c5..3c0b05cd69 100644
--- a/community/tcsh/tcsh.pre-deinstall
+++ b/community/tcsh/tcsh.pre-deinstall
@@ -1,3 +1,4 @@
#!/bin/sh
+remove-shell '/bin/csh'
remove-shell '/bin/tcsh'
exit 0