aboutsummaryrefslogtreecommitdiffstats
path: root/community/telegram-desktop
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-05-01 14:13:09 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-02 09:36:51 +0000
commit7b4050e9c2b306ba9ed51896a82fe162ad866c30 (patch)
tree63be13d05e920ce4fc4218ab5f555bb7102ca581 /community/telegram-desktop
parent6856fadbfae5855ba647b5c2a6d8c5f011ecacca (diff)
downloadaports-7b4050e9c2b306ba9ed51896a82fe162ad866c30.tar.bz2
aports-7b4050e9c2b306ba9ed51896a82fe162ad866c30.tar.xz
community/telegram-desktop: fix install location for desktop and appdata file
These should be named after the app id that they contain info about. Also don't manually strip the telegram-desktop binary, it's already getting stripped automatically by abuild
Diffstat (limited to 'community/telegram-desktop')
-rw-r--r--community/telegram-desktop/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/community/telegram-desktop/APKBUILD b/community/telegram-desktop/APKBUILD
index 24a294c60a..768d1e456f 100644
--- a/community/telegram-desktop/APKBUILD
+++ b/community/telegram-desktop/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
pkgname=telegram-desktop
pkgver=2.1.1
-pkgrel=0
+pkgrel=1
pkgdesc="Telegram Desktop messaging app"
options="!check" # Requires Catch2 to be packaged.
url="https://desktop.telegram.org/"
@@ -78,10 +78,9 @@ package() {
"$pkgdir"/usr/share/appdata \
"$pkgdir"/usr/share/kservices5 \
- strip -s build/bin/telegram-desktop
install -m755 build/bin/telegram-desktop -t "$pkgdir"/usr/bin
- install -m644 lib/xdg/telegramdesktop.desktop -t "$pkgdir"/usr/share/applications
- install -m644 build/Telegram/telegramdesktop.appdata.xml -t "$pkgdir"/usr/share/appdata
+ install -m644 lib/xdg/telegramdesktop.desktop "$pkgdir"/usr/share/applications/org.telegram.desktop.desktop
+ install -m644 build/Telegram/telegramdesktop.appdata.xml "$pkgdir"/usr/share/appdata/org.telegram.desktop.appdata.xml
for icon_size in 16 32 48 64 128 256 512; do
icon_dir="$pkgdir/usr/share/icons/hicolor/${icon_size}x$icon_size/apps"