aboutsummaryrefslogtreecommitdiffstats
path: root/community/terraform
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-22 02:17:35 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-22 04:08:55 -0300
commitf820cc765bda6e5db786755ec824d855f61501ce (patch)
tree660be9f28e9d55f1f80c72a5c8dfb12fa228f639 /community/terraform
parentdc407b2a4f71781a5bbad3b5727d3bec398cfa71 (diff)
downloadaports-f820cc765bda6e5db786755ec824d855f61501ce.tar.bz2
aports-f820cc765bda6e5db786755ec824d855f61501ce.tar.xz
community/terraform: upgrade to 0.12.12
Diffstat (limited to 'community/terraform')
-rw-r--r--community/terraform/APKBUILD6
1 files changed, 2 insertions, 4 deletions
diff --git a/community/terraform/APKBUILD b/community/terraform/APKBUILD
index 911a3d42c8..63412863a0 100644
--- a/community/terraform/APKBUILD
+++ b/community/terraform/APKBUILD
@@ -3,7 +3,7 @@
# Contributor: Sergii Sadovyi <serg.sadovoi@gmail.com>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=terraform
-pkgver=0.12.10
+pkgver=0.12.12
pkgrel=0
pkgdesc="Building, changing and combining infrastructure safely and efficiently"
url="https://www.terraform.io/"
@@ -20,13 +20,11 @@ prepare() {
}
build() {
- cd "$builddir"
GO111MODULE=off GOPATH="$srcdir" go build -v -o bin/$pkgname \
-ldflags "-X main.GitCommit=v$pkgver -X github.com/hashicorp/terraform/version.Prerelease= -s -w"
}
check() {
- cd "$builddir"
GOPATH="$srcdir" go list -mod=vendor . | xargs -t -n4 go test -mod=vendor -timeout=2m -parallel=4
bin/$pkgname -v
}
@@ -40,4 +38,4 @@ cleanup_srcdir() {
default_cleanup_srcdir
}
-sha512sums="8d97999a34b2920f8597c797d0db9ebfb12da0de718efb2eab0b69857227545147c8dba7bde8a3e2c82bb101c9b50a61c5a5ec2d490b7ffd2e712c1de80b1185 terraform-0.12.10.tar.gz"
+sha512sums="58e15da1cc5345e7780573bfeda4a6f34dc281682a0e3f7bf6b129d0db42ff343b79575bb06472e1c994f8d3e3d7e3ab507a4a09f1cfd166690a611af221bd8e terraform-0.12.12.tar.gz"