aboutsummaryrefslogtreecommitdiffstats
path: root/community/terraform
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-21 18:54:44 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-07-21 23:38:50 +0200
commitf96c6f154f3002b05d3dedf27e3e768b6e1ff996 (patch)
tree1dd00062801abbd037d7e5d56af56f527304f61f /community/terraform
parent21e5cf4d96df4b6256d19cb3e5568555723d482b (diff)
downloadaports-f96c6f154f3002b05d3dedf27e3e768b6e1ff996.tar.bz2
aports-f96c6f154f3002b05d3dedf27e3e768b6e1ff996.tar.xz
commmunity/terraform: upgrade to 0.9.11
Diffstat (limited to 'community/terraform')
-rw-r--r--community/terraform/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/terraform/APKBUILD b/community/terraform/APKBUILD
index 1838bb4156..debc7848f6 100644
--- a/community/terraform/APKBUILD
+++ b/community/terraform/APKBUILD
@@ -2,32 +2,30 @@
# Contributor: Gennady Feldman <gena01@gmail.com>
# Maintainer: Thomas Boerger <thomas@webhippie.de>
pkgname=terraform
-pkgver=0.9.5
+pkgver=0.9.11
pkgrel=0
pkgdesc="Building, changing, and combining infrastructure safely and efficiently"
url="https://www.terraform.io/"
arch="all !armhf"
license="MPL 2.0"
-depends=""
makedepends="go"
-install=""
source="${pkgname}-${pkgver}.tar.gz::https://github.com/hashicorp/terraform/archive/v$pkgver.tar.gz"
builddir="$srcdir/src/github.com/hashicorp/$pkgname"
prepare() {
mkdir -p ${builddir%/*}
- mv $srcdir/$pkgname-$pkgver "$builddir"/ || return 1
+ mv $srcdir/$pkgname-$pkgver "$builddir"/
default_prepare
}
build() {
cd "$builddir"
export GOPATH="$srcdir"
- go build -v -o bin/$pkgname || return 1
+ go build -v -o bin/$pkgname
}
package() {
- install -Dm755 "$builddir"/bin/$pkgname "$pkgdir"/usr/bin/$pkgname || return 1
+ install -Dm755 "$builddir"/bin/$pkgname "$pkgdir"/usr/bin/$pkgname
}
-sha512sums="0c2dba9cc864c7c16d5b1d5d0c7e1980780589cdb3d76f3d9bb08b9f3fa99221f3daeaca04d3776157e7cdfdf28b9e4413e8ce1857bc672b212bfb52e17ed40c terraform-0.9.5.tar.gz"
+sha512sums="73c16c8bf1e006bce23db26657de7ad130c049c137c23c0fd82c509a145303ebdac141b971f87d9cd0d5b193ca262c09787ff879e5588b90f87a764874b509db terraform-0.9.11.tar.gz"