aboutsummaryrefslogtreecommitdiffstats
path: root/community/texmf-dist/APKBUILD
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-07 22:31:06 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-07 22:31:06 +0000
commit0ebeff49d1c8e4571f5d767a6b67a9279ae99079 (patch)
tree556d22fd2c79fce07bc48a0bfaf41b9deaacb83d /community/texmf-dist/APKBUILD
parentd67a4bfb8a105f3c9a1e097e1a40e36b8f12bf8c (diff)
downloadaports-0ebeff49d1c8e4571f5d767a6b67a9279ae99079.tar.bz2
aports-0ebeff49d1c8e4571f5d767a6b67a9279ae99079.tar.xz
community/texmf-dist: fix up pack_subpkg
Diffstat (limited to 'community/texmf-dist/APKBUILD')
-rw-r--r--community/texmf-dist/APKBUILD38
1 files changed, 20 insertions, 18 deletions
diff --git a/community/texmf-dist/APKBUILD b/community/texmf-dist/APKBUILD
index a643bbf461..96322f06bb 100644
--- a/community/texmf-dist/APKBUILD
+++ b/community/texmf-dist/APKBUILD
@@ -113,12 +113,14 @@ package() {
}
pack_subpkg() {
+ local our_pkgver="$1"
+
# See comment in package(), same applies here
mkdir -p "${subpkgdir}/usr/share/"
mkdir -p "${srcdir}/pkgs-packed"
mkdir -p "${srcdir}/pkgs-unpacked"
cd "${srcdir}/pkgs-packed"
- unzip "${srcdir}/texlive-${subpkgname#texmf-dist-}-${pkgver}-src.zip" > /dev/null
+ unzip "${srcdir}/texlive-${subpkgname#texmf-dist-}-${our_pkgver}-src.zip" > /dev/null
cd "${srcdir}/pkgs-unpacked"
find "${srcdir}/pkgs-packed" -name '*.tar.xz' -exec tar -xf {} \;
find . -maxdepth 1 -name 'texmf*' -exec mv {} "${subpkgdir}/usr/share/" \;
@@ -175,87 +177,87 @@ full() {
bibtexextra() {
pkgdesc="TeX Live texmf distribution: Additional BibTeX styles and bibliography DBs"
- pack_subpkg
+ pack_subpkg "$_bibtexextra"
}
fontsextra() {
pkgdesc="TeX Live texmf distribution: Additional fonts"
- pack_subpkg
+ pack_subpkg "$_fontsextra"
}
formatsextra() {
pkgdesc="TeX Live texmf distribution: Additional TeX formats"
- pack_subpkg
+ pack_subpkg "$_formatsextra"
}
games() {
pkgdesc="TeX Live texmf distribution: Typesetting board games including chess"
- pack_subpkg
+ pack_subpkg "$_games"
}
humanities() {
pkgdesc="TeX Live texmf distribution: Packages for humanities, law, linguistics, ..."
- pack_subpkg
+ pack_subpkg "$_humanities"
}
langchinese() {
pkgdesc="TeX Live texmf distribution: Support for Chinese"
- pack_subpkg
+ pack_subpkg "$_langchinese"
}
langcyrillic() {
pkgdesc="TeX Live texmf distribution: Support for Cyrillic languages"
- pack_subpkg
+ pack_subpkg "$_langcyrillic"
}
langextra() {
pkgdesc="TeX Live texmf distribution: Additional languages"
- pack_subpkg
+ pack_subpkg "$_langextra"
}
langgreek() {
pkgdesc="TeX Live texmf distribution: Support for Greek"
- pack_subpkg
+ pack_subpkg "$_langgreek"
}
langjapanese() {
pkgdesc="TeX Live texmf distribution: Support for Japanese"
- pack_subpkg
+ pack_subpkg "$_langjapanese"
}
langkorean() {
pkgdesc="TeX Live texmf distribution: Support for Korean"
- pack_subpkg
+ pack_subpkg "$_langkorean"
}
latexextra() {
pkgdesc="TeX Live texmf distribution: Add-onpackages for LaTeX"
- pack_subpkg
+ pack_subpkg "$_latexextra"
}
music() {
pkgdesc="TeX Live texmf distribution: Music typesetting packages"
- pack_subpkg
+ pack_subpkg "$_music"
}
pictures() {
pkgdesc="TeX Live texmf distribution: Packages for drawing graphics"
- pack_subpkg
+ pack_subpkg "$_pictures"
}
pstricks() {
pkgdesc="TeX Live texmf distribution: Additional PSTricks packages"
- pack_subpkg
+ pack_subpkg "$_pstricks"
}
publishers() {
pkgdesc="TeX Live texmf distribution: LaTeX packages for specific publishers"
- pack_subpkg
+ pack_subpkg "$_publishers"
}
science() {
pkgdesc="TeX Live texmf distribution: Typesetting for math and sciences"
- pack_subpkg
+ pack_subpkg "$_science"
}
sha512sums="85823ca890894ea58a118519301ed836000ace5217dcb79cd6f099d0a8e239087beb81aa85bd514a7af9ed1462973f5562d3e07e22f9625ef232330a904efecf texlive-core-2017.45811-src.zip