aboutsummaryrefslogtreecommitdiffstats
path: root/community/tilda
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2017-06-19 09:24:15 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2017-06-19 09:24:15 +0000
commitc2608d3ee64ad09c79073fc45e14d6d2cbfff87c (patch)
tree9167263fd1509c4f360510fc3f8267b0115da115 /community/tilda
parentb7b12019f7674a67d639505fff7fa082b0d73979 (diff)
downloadaports-c2608d3ee64ad09c79073fc45e14d6d2cbfff87c.tar.bz2
aports-c2608d3ee64ad09c79073fc45e14d6d2cbfff87c.tar.xz
community/tilda: clean up APKBUILD, added check() function
Diffstat (limited to 'community/tilda')
-rw-r--r--community/tilda/APKBUILD26
1 files changed, 8 insertions, 18 deletions
diff --git a/community/tilda/APKBUILD b/community/tilda/APKBUILD
index 7c6202e8de..d4200bb2f2 100644
--- a/community/tilda/APKBUILD
+++ b/community/tilda/APKBUILD
@@ -7,37 +7,27 @@ pkgdesc="A Gtk based drop down terminal for Linux and Unix"
url="https://github.com/lanoxx/tilda"
arch="all"
license="GPL"
-depends=""
-depends_dev=""
-makedepends="$depends_dev automake autoconf libtool confuse-dev vte3-dev"
-install=""
+makedepends="automake autoconf libtool confuse-dev vte3-dev"
subpackages="$pkgname-lang"
source="https://github.com/lanoxx/$pkgname/archive/$pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$pkgname-$pkgname-$pkgver
-_builddir="$srcdir"/$pkgname-$pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+check() {
+ cd "$builddir"
+ make check
}
build() {
- cd "$_builddir"
+ cd "$builddir"
./autogen.sh
./configure \
--prefix=/usr
- make || return 1
+ make
}
package() {
- cd "$_builddir"
+ cd "$builddir"
make DESTDIR="${pkgdir}" install
}
-md5sums="785b0df315135ed283715f823b78cf87 tilda-1.3.3.tar.gz"
-sha256sums="71baa5572c498e5b3e94f5b57e8118c1ef0fdaea269a5b2425208e1adec284b1 tilda-1.3.3.tar.gz"
sha512sums="7327159201cd1a17a3633bd8d399283564487d3bf36ff16d31d4efd3839ddf79661d3160fe67c85db2f60bc5283ac4ff2d8ea0738e8ea7dc3ce538cfcb68f951 tilda-1.3.3.tar.gz"