aboutsummaryrefslogtreecommitdiffstats
path: root/community/tini
diff options
context:
space:
mode:
authorDanilo Bürger <info@danilobuerger.de>2016-02-04 23:09:47 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2016-02-05 11:31:56 +0000
commitc081bef5cbf4b1f506a95bb1acf9cad341b5dfca (patch)
tree21fec411a2726cd62cc20663cc50780745efafd3 /community/tini
parentc61a0ebd7b600bbe355244cda670da6b1ed3ade9 (diff)
downloadaports-c081bef5cbf4b1f506a95bb1acf9cad341b5dfca.tar.bz2
aports-c081bef5cbf4b1f506a95bb1acf9cad341b5dfca.tar.xz
testing/tini: moved to community
Diffstat (limited to 'community/tini')
-rw-r--r--community/tini/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/tini/APKBUILD b/community/tini/APKBUILD
new file mode 100644
index 0000000000..66bbfd0383
--- /dev/null
+++ b/community/tini/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Danilo Bürger <danilo@feastr.de>
+
+pkgname=tini
+pkgver=0.9.0
+pkgrel=0
+pkgdesc="A tiny but valid init for containers"
+url="https://github.com/krallin/tini"
+arch="all"
+license="MIT"
+depends=""
+depends_dev=""
+makedepends="$depends_dev cmake"
+install=""
+subpackages=""
+source="$pkgname-$pkgver.tar.gz::https://github.com/krallin/tini/archive/v$pkgver.tar.gz"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$_builddir"
+ export CFLAGS="-DPR_SET_CHILD_SUBREAPER=36 -DPR_GET_CHILD_SUBREAPER=37"
+ cmake . || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ install -D -m755 tini "$pkgdir"/usr/bin/tini || return 1
+}
+
+md5sums="efd014cf45babe76415c4d6caee643d8 tini-0.9.0.tar.gz"
+sha256sums="e327772e52b6c696650401b09677e34d5d72dda19036a0300994b99c9a123bbb tini-0.9.0.tar.gz"
+sha512sums="6eb75390903b76e5f9eed92df387362d079c2b7df1976171dfcbdcf0c97e587514f21b0d1a7c4d9f607dffe16ab4d5582eb02890abb658c176123e8b29e5fe86 tini-0.9.0.tar.gz"