aboutsummaryrefslogtreecommitdiffstats
path: root/community/tl-expected
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-14 00:59:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-14 09:18:01 -0300
commit35cb9323a1ed0b44d594f9f3f58f08ba600648f0 (patch)
tree69a1b83f65abe37c6a14bb8844178b2640f7f5aa /community/tl-expected
parent702eb5be91d1a56eed07ced403d93bbbd174da31 (diff)
downloadaports-35cb9323a1ed0b44d594f9f3f58f08ba600648f0.tar.bz2
aports-35cb9323a1ed0b44d594f9f3f58f08ba600648f0.tar.xz
community/tl-expected: move from testing
Diffstat (limited to 'community/tl-expected')
-rw-r--r--community/tl-expected/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/tl-expected/APKBUILD b/community/tl-expected/APKBUILD
new file mode 100644
index 0000000000..331d2f97aa
--- /dev/null
+++ b/community/tl-expected/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=tl-expected
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="C++11/14/17 std::expected with functional-style extensions"
+options="!check"
+url="https://github.com/TartanLlama/expected"
+arch="noarch"
+license="CC0-1.0"
+makedepends="cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/TartanLlama/expected/archive/v$pkgver.tar.gz"
+builddir="$srcdir/expected-$pkgver"
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DBUILD_SHARED_LIBS=True \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DEXPECTED_ENABLE_TESTS=OFF \
+ ${CMAKE_CROSSOPTS} .
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="747ea34b5540dfcf595896332851f10c52a823ab8ba3fc8152478b0a9e8ca01f0f26827348407249827f4106ff577bd6e697ea6f749c1f21bd1f0913a621075d tl-expected-1.0.0.tar.gz"