aboutsummaryrefslogtreecommitdiffstats
path: root/community/tomahawk
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-07-23 18:23:49 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-07-24 13:19:19 +0000
commit38857717dce12bba0172e191de225561b698db6c (patch)
tree9ec441fff379b274a848462cb5233a9e79fb3012 /community/tomahawk
parent5ff3c059459eaf7a71559f1268b9af4aa75e498f (diff)
downloadaports-38857717dce12bba0172e191de225561b698db6c.tar.bz2
aports-38857717dce12bba0172e191de225561b698db6c.tar.xz
community/tomahawk: modernize APKBUILD
Diffstat (limited to 'community/tomahawk')
-rw-r--r--community/tomahawk/APKBUILD29
1 files changed, 6 insertions, 23 deletions
diff --git a/community/tomahawk/APKBUILD b/community/tomahawk/APKBUILD
index 3aac626a40..205fd98b49 100644
--- a/community/tomahawk/APKBUILD
+++ b/community/tomahawk/APKBUILD
@@ -13,49 +13,32 @@ depends_dev="qt-dev phonon-dev boost-dev gnutls-dev qtkeychain-dev
liblastfm-dev qtkeychain-dev jreen-dev"
makedepends="$depends_dev cmake sparsehash websocket++ automoc4 linux-headers
bsd-compat-headers"
-install=""
subpackages="$pkgname-dev"
source="http://download.tomahawk-player.org/tomahawk-$pkgver.tar.bz2
musl-fixes.patch
compare-taglib-version.patch
"
-_builddir="$srcdir"/tomahawk-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver
build() {
- mkdir "$_builddir"/build
- cd "$_builddir"/build
- cmake "$_builddir" \
+ mkdir "$builddir"/build
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DFORCE_QT4=ON \
-DCMAKE_INSTALL_LIBEXECDIR=lib/${pkgname} \
-DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=Release \
- || return 1
+ -DCMAKE_BUILD_TYPE=Release
}
package() {
- cd "$_builddir"/build
+ cd "$builddir"/build
make DESTDIR=${pkgdir} install
}
-md5sums="04832abe1786edcc55805875b5882445 tomahawk-0.8.4.tar.bz2
-d544233b9cca0be6b4fda9855b8a4cfa musl-fixes.patch
-c8765414d69411b557be371c12d8ee89 compare-taglib-version.patch"
-sha256sums="0fb04bc6b7009e17186b3d384057939727c6f289d22f7f9a5ed2c9c9cd800449 tomahawk-0.8.4.tar.bz2
-a1797803b2db585b001ff21c9609d59cccf6451670e695da12ff66e6dc5e7d10 musl-fixes.patch
-ecc8b0968d7787d9163b0dc3efbae44ffd1947f96948a3c26a798a83a18cafbe compare-taglib-version.patch"
sha512sums="5b312f593eac39d06de05e24d4ce429122d0777a9d52d6db8c65309ac283d7ae560c2fc189b186f0f8b1a7bbe1135ed0d59e1d850de6a93655e53efe4f5317c7 tomahawk-0.8.4.tar.bz2
eaf3a13d6e664999820aa562921462ca51e3abea464fd4fba3864ac9cac723b13fa5d349feea88a4c44356348bab127dda0899fb6335e610a8e4f5172d55b1d9 musl-fixes.patch
a09e7d4e9bc684ca51714795716dd1756e490c2824371824313f53b0f0008c5fcfe95bceefd237d8d9c2b553760639848251770140739bc401b77a2b4e44c77c compare-taglib-version.patch"