aboutsummaryrefslogtreecommitdiffstats
path: root/community/ttf-cantarell
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 03:12:41 +0000
committerWilliam Pitcock <nenolod@dereferenced.org>2018-03-01 03:12:41 +0000
commit49c8151dbbe037bd2f66c8dcb9f3b91986bd78b8 (patch)
treeb6497b28be416f97712d0508b331bef0c38be365 /community/ttf-cantarell
parent29a98480c792fb7897d02479235ab03180e943df (diff)
downloadaports-49c8151dbbe037bd2f66c8dcb9f3b91986bd78b8.tar.bz2
aports-49c8151dbbe037bd2f66c8dcb9f3b91986bd78b8.tar.xz
community/ttf-cantarell: move from testing
Diffstat (limited to 'community/ttf-cantarell')
-rw-r--r--community/ttf-cantarell/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/community/ttf-cantarell/APKBUILD b/community/ttf-cantarell/APKBUILD
new file mode 100644
index 0000000000..8d14472aed
--- /dev/null
+++ b/community/ttf-cantarell/APKBUILD
@@ -0,0 +1,37 @@
+# Maintainer: William Pitcock <nenolod@dereferenced.org>
+pkgname=ttf-cantarell
+pkgver=0.0.25
+pkgrel=0
+pkgdesc="GNOME default font"
+url="https://wiki.gnome.org/Projects/CantarellFonts"
+arch="noarch"
+license="Custom"
+depends=""
+makedepends=""
+install=""
+install_if="gnome-shell"
+subpackages=""
+source="https://download.gnome.org/sources/cantarell-fonts/${pkgver%.*}/cantarell-fonts-$pkgver.tar.xz"
+builddir="$srcdir/cantarell-fonts-$pkgver"
+
+# it's just data, no testsuites
+options="!check"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c09c3ecb3d4c50f613234398fabd327ca92b8abbc27082e8e98f2944f3dd9f0c2ff4c022ff5e5503a86e724bb8e2fbf6cd081f8a29e91b4209f5bf0e32168c3e cantarell-fonts-0.0.25.tar.xz"