aboutsummaryrefslogtreecommitdiffstats
path: root/community/ttyd/fix-cmake.patch
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-12 10:58:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-12 11:59:31 -0300
commit8b4ef97cee541a0bbb815d15d6be2fb1f7e38b21 (patch)
tree73554d50e0819a8a2822de5160bac44d7a5d7ae6 /community/ttyd/fix-cmake.patch
parentdcf0532b217ff0324dd9cb5440045fffa603c1c0 (diff)
downloadaports-8b4ef97cee541a0bbb815d15d6be2fb1f7e38b21.tar.bz2
aports-8b4ef97cee541a0bbb815d15d6be2fb1f7e38b21.tar.xz
community/ttyd: upgrade to 1.6.0
Diffstat (limited to 'community/ttyd/fix-cmake.patch')
-rw-r--r--community/ttyd/fix-cmake.patch23
1 files changed, 8 insertions, 15 deletions
diff --git a/community/ttyd/fix-cmake.patch b/community/ttyd/fix-cmake.patch
index 274bfcb7ef..82d5cb87d5 100644
--- a/community/ttyd/fix-cmake.patch
+++ b/community/ttyd/fix-cmake.patch
@@ -1,20 +1,13 @@
-find_package doesn't find Libwebsockets (with capital "L"). Eventually it finds
-libwebsockets with pkg-config, but includes libwebsockets.a on the path first,
-so the resulting library links libwebsockets statically.
-
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 8061f47..f9382ed 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
-@@ -13,11 +13,11 @@
- set(SOURCE_FILES src/server.c src/http.c src/protocol.c src/utils.c)
+@@ -53,7 +53,7 @@ endif()
find_package(OpenSSL REQUIRED)
--find_package(Libwebsockets ${LIBWEBSOCKETS_MIN_VERSION} QUIET)
-+find_package(libwebsockets ${LIBWEBSOCKETS_MIN_VERSION} QUIET)
+ find_package(ZLIB REQUIRED)
+-find_package(Libwebsockets 1.7.0 QUIET)
++find_package(libwebsockets 1.7.0 QUIET)
- find_package(PkgConfig)
-
--if(Libwebsockets_FOUND)
-+if(libwebsockets_FOUND)
- set(LIBWEBSOCKETS_INCLUDE_DIR ${LIBWEBSOCKETS_INCLUDE_DIR} ${LIBWEBSOCKETS_INCLUDE_DIRS})
- else() # try to find libwebsockets with pkg-config
- pkg_check_modules(Libwebsockets REQUIRED libwebsockets>=${LIBWEBSOCKETS_MIN_VERSION})
+ if(NOT Libwebsockets_FOUND) # for libwebsockets-dev on ubuntu 16.04
+ find_path(LIBWEBSOCKETS_INCLUDE_DIR NAMES libwebsockets.h)