aboutsummaryrefslogtreecommitdiffstats
path: root/community/tvheadend
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-09 19:20:26 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-09 20:00:28 -0300
commit315d1e147d063cc5bf7b67025a9a9aafbc7b9ada (patch)
treecb2bc7020c83a57f320b6a82b5486a1d31f1225b /community/tvheadend
parent44bd4d4913d9a13381120a8c3df198d9a473513a (diff)
downloadaports-315d1e147d063cc5bf7b67025a9a9aafbc7b9ada.tar.bz2
aports-315d1e147d063cc5bf7b67025a9a9aafbc7b9ada.tar.xz
community/tvheadend: use python3, drop hdhomerun
Diffstat (limited to 'community/tvheadend')
-rw-r--r--community/tvheadend/APKBUILD15
1 files changed, 4 insertions, 11 deletions
diff --git a/community/tvheadend/APKBUILD b/community/tvheadend/APKBUILD
index 5fbba14159..e4894963ce 100644
--- a/community/tvheadend/APKBUILD
+++ b/community/tvheadend/APKBUILD
@@ -1,16 +1,13 @@
# Maintainer: Carlo Landmeter <clandmeter@alpinelinux.org>
pkgname=tvheadend
pkgver=4.2.8
-pkgrel=0
+pkgrel=1
pkgdesc="TV Streaming server for linux"
url="http://tvheadend.org/"
arch="all"
license="GPL-3.0-only"
-depends=""
-depends_dev=""
-makedepends="$depends_dev findutils bash git python2 linux-headers
- bsd-compat-headers coreutils openssl-dev ffmpeg-dev gettext-dev
- zlib-dev libhdhomerun-dev cmake"
+makedepends="findutils bash git python3 linux-headers bsd-compat-headers
+ coreutils openssl-dev ffmpeg-dev gettext-dev zlib-dev cmake"
pkgusers="tvheadend"
pkggroups="tvheadend"
install="$pkgname.pre-install"
@@ -20,18 +17,14 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/tvheadend/tvheadend/archive/
$pkgname.initd
"
-builddir="$srcdir/tvheadend-$pkgver"
build() {
- cd "$builddir"
./configure --prefix=/usr \
--sysconfdir=/etc \
--mandir=/usr/share/man \
--infodir=/usr/share/info \
--localstatedir=/var \
--enable-libav \
- --enable-hdhomerun_client \
- --disable-hdhomerun_static \
--disable-ffmpeg_static \
--disable-libx264_static \
--disable-libx265_static \
@@ -40,12 +33,12 @@ build() {
--disable-libvorbis_static \
--disable-libfdkaac_static \
--disable-libmfx_static \
+ --python=python3 \
--nowerror
make
}
package() {
- cd "$builddir"
make -j1 DESTDIR="$pkgdir" install
install -m 755 -D "$srcdir"/$pkgname.initd \
"$pkgdir"/etc/init.d/$pkgname