aboutsummaryrefslogtreecommitdiffstats
path: root/community/ucl
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-08 02:00:14 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-03-08 02:00:14 +0100
commit2fc8f658e0323f005e5257da457c1a5c151a0ff7 (patch)
tree1de3f71e6e5359ea7fc514091e6890d71d88f9f9 /community/ucl
parent339244bc540e25295c5a4d055d209fa19320a9d2 (diff)
downloadaports-2fc8f658e0323f005e5257da457c1a5c151a0ff7.tar.bz2
aports-2fc8f658e0323f005e5257da457c1a5c151a0ff7.tar.xz
community/ucl: move from testing
Diffstat (limited to 'community/ucl')
-rw-r--r--community/ucl/0001-Static-assert.patch34
-rw-r--r--community/ucl/APKBUILD42
2 files changed, 76 insertions, 0 deletions
diff --git a/community/ucl/0001-Static-assert.patch b/community/ucl/0001-Static-assert.patch
new file mode 100644
index 0000000000..bdf4900384
--- /dev/null
+++ b/community/ucl/0001-Static-assert.patch
@@ -0,0 +1,34 @@
+From: Robert Luberda <robert@debian.org>
+Date: Sat, 2 Jul 2016 22:23:20 +0200
+Subject: Switch to _Static_assert
+
+Use _Static_assert for compile-time assertion to fix
+build failures with gcc-6 (closes: #811707)
+---
+ acc/acc_defs.h | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/acc/acc_defs.h b/acc/acc_defs.h
+index 866b7bd..5ee3761 100644
+--- a/acc/acc_defs.h
++++ b/acc/acc_defs.h
+@@ -87,6 +87,9 @@
+
+ /* This can be put into a header file but may get ignored by some compilers. */
+ #if !defined(ACC_COMPILE_TIME_ASSERT_HEADER)
++# define ACC_COMPILE_TIME_ASSERT_HEADER(e) _Static_assert(e, #e);
++#endif
++#if !defined(ACC_COMPILE_TIME_ASSERT_HEADER)
+ # if (ACC_CC_AZTECC || ACC_CC_ZORTECHC)
+ # define ACC_COMPILE_TIME_ASSERT_HEADER(e) extern int __acc_cta[1-!(e)];
+ # elif (ACC_CC_DMC || ACC_CC_SYMANTECC)
+@@ -100,6 +103,9 @@
+
+ /* This must appear within a function body. */
+ #if !defined(ACC_COMPILE_TIME_ASSERT)
++# define ACC_COMPILE_TIME_ASSERT(e) _Static_assert(e, #e);
++#endif
++#if !defined(ACC_COMPILE_TIME_ASSERT)
+ # if (ACC_CC_AZTECC)
+ # define ACC_COMPILE_TIME_ASSERT(e) {typedef int __acc_cta_t[1-!(e)];}
+ # elif (ACC_CC_DMC || ACC_CC_PACIFICC || ACC_CC_SYMANTECC || ACC_CC_ZORTECHC)
diff --git a/community/ucl/APKBUILD b/community/ucl/APKBUILD
new file mode 100644
index 0000000000..b9e73b9ae0
--- /dev/null
+++ b/community/ucl/APKBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Mitch Tishmack <mitch.tishmack@gmail.com>
+pkgname=ucl
+pkgver=1.03
+pkgrel=1
+pkgdesc="Portable lossless data compression library written in ANSI C"
+url="http://www.oberhumer.com/opensource/ucl/"
+arch="all"
+license="GPL2"
+makedepends="file"
+subpackages="$pkgname-dev"
+source="http://www.oberhumer.com/opensource/$pkgname/download/$pkgname-$pkgver.tar.gz
+ 0001-Static-assert.patch"
+
+prepare() {
+ default_prepare || return 1
+ update_config_sub || return 1
+ update_config_guess || return 1
+}
+
+build() {
+ cd "$builddir"
+
+ ./configure \
+ --prefix=/usr \
+ --enable-shared \
+ --enable-static \
+ || return 1
+ make || return 1
+}
+
+check() {
+ cd "$builddir"
+ ./examples/simple
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="7dd1824d01b4bb41ee03bbceddc634a9f7f910d235e5cca163d783680d6743f0f3cc309bbbcc1e094d897d549d3805a555f9093b4d77805443d896dd1862aa34 ucl-1.03.tar.gz
+24a34de871fcfa919985afc29c60496b1f0e730550e8387f212a5229f32ccade4178d1221574d86c36d025c08b3b5ed6d236f2b4d740436afe0451ae9050f890 0001-Static-assert.patch"