aboutsummaryrefslogtreecommitdiffstats
path: root/community/uncrustify
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 14:12:19 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 14:53:00 -0300
commit5857fb2b57fdaf5f93aca5d018dd3c911bc2cf12 (patch)
treef3e05620312fe996188d9e2179fd9bce871672b2 /community/uncrustify
parentd6388a4ff66d4c3d7bb22ccb003745f16f6697ec (diff)
downloadaports-5857fb2b57fdaf5f93aca5d018dd3c911bc2cf12.tar.bz2
aports-5857fb2b57fdaf5f93aca5d018dd3c911bc2cf12.tar.xz
community/uncrustify: modernize
Diffstat (limited to 'community/uncrustify')
-rw-r--r--community/uncrustify/APKBUILD22
1 files changed, 9 insertions, 13 deletions
diff --git a/community/uncrustify/APKBUILD b/community/uncrustify/APKBUILD
index 9facaac0d0..3e6d41cdfa 100644
--- a/community/uncrustify/APKBUILD
+++ b/community/uncrustify/APKBUILD
@@ -1,8 +1,8 @@
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=uncrustify
pkgver=0.70.1
-pkgrel=0
-pkgdesc="A source code beautifier"
+pkgrel=1
+pkgdesc="Source code beautifier"
url="https://github.com/uncrustify/uncrustify"
arch="all"
license="GPL-2.0-or-later"
@@ -13,24 +13,20 @@ builddir="$srcdir/uncrustify-uncrustify-$pkgver"
build() {
[ "$CARCH" = "s390x" ] && sed -i '/^12004/d' tests/c-sharp.test
- mkdir -p build
- cd build
- cmake -DCMAKE_INSTALL_PREFIX=/usr ..
- make
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make -C build
}
check() {
- cd "$builddir/build"
- make test
+ make -C build test
}
package() {
- install -d -m755 "$pkgdir"/usr/share/$pkgname
- install -m644 etc/*.cfg "$pkgdir"/usr/share/$pkgname
- install -Dm644 COPYING "$pkgdir"/usr/share/licenses/$pkgname/COPYING
+ make -C build DESTDIR="$pkgdir" PREFIX=/usr install
- cd build
- make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm644 etc/*.cfg -t "$pkgdir"/usr/share/$pkgname
}
sha512sums="d28f02d5c82e3b398fd0391fe49eb1260a905e525c7c4b513ccea68ffff480d96cd77936267dd7d6870a59903c72578efc0ff85696c877caf1f1c89160c79334 uncrustify-0.70.1.tar.gz"