aboutsummaryrefslogtreecommitdiffstats
path: root/community/unison
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-09 22:42:40 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:17:25 +0100
commit74ff07c2c66e578127fefde3120bc8ae8268f151 (patch)
tree4992fd1e1c81ffc2c0b130d21a70009393dbdf29 /community/unison
parentd7643405faad0171da012b68b6c89702f5f6acb7 (diff)
downloadaports-74ff07c2c66e578127fefde3120bc8ae8268f151.tar.bz2
aports-74ff07c2c66e578127fefde3120bc8ae8268f151.tar.xz
community/unison: upgrade to 2.48.15v4, remove -doc
HTML page for this version is not available.
Diffstat (limited to 'community/unison')
-rw-r--r--community/unison/APKBUILD31
-rw-r--r--community/unison/fix-for-lablgtk-2.18.6.patch20
-rw-r--r--community/unison/fix-inotify-check.patch12
-rw-r--r--community/unison/fix_inotify_check.patch13
-rw-r--r--community/unison/makefile-fix-clean.patch25
-rw-r--r--community/unison/marshalling.patch16
6 files changed, 71 insertions, 46 deletions
diff --git a/community/unison/APKBUILD b/community/unison/APKBUILD
index 40c1b8e0dd..0327c9618f 100644
--- a/community/unison/APKBUILD
+++ b/community/unison/APKBUILD
@@ -1,8 +1,9 @@
# Contributor: Jean-Louis Fuchs <ganwell@fangorn.ch>
# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
pkgname=unison
-pkgver=2.48.4
-pkgrel=4
+pkgver=2.48.15.4
+_pkgver=${pkgver%.*}v${pkgver##*.}
+pkgrel=0
pkgdesc="Unison - efficient file-synchronization tool"
url="https://www.cis.upenn.edu/~bcpierce/unison/"
# ocaml is not built for x86, armhf, s390x
@@ -10,15 +11,15 @@ url="https://www.cis.upenn.edu/~bcpierce/unison/"
arch="all !x86 !armhf !aarch64 !s390x"
license="GPL-3.0+"
makedepends="ocaml ocaml-lablgtk-dev linux-headers emacs-nox bash"
-subpackages="$pkgname-doc $pkgname-gui"
-source="http://www.seas.upenn.edu/~bcpierce/unison/download/releases/stable/unison-$pkgver.tar.gz
- http://www.seas.upenn.edu/~bcpierce/unison/download/releases/stable/unison-$pkgver-manual.html
- fix_inotify_check.patch
- marshalling.patch"
+subpackages="$pkgname-gui"
+source="$pkgname-$_pkgver.tar.gz::https://github.com/bcpierce00/$pkgname/archive/v$_pkgver.tar.gz
+ fix-inotify-check.patch
+ makefile-fix-clean.patch
+ fix-for-lablgtk-2.18.6.patch"
# TODO: Enable check once this issue is fixed:
# https://github.com/bcpierce00/unison/issues/73
options="!check"
-builddir="$srcdir/src"
+builddir="$srcdir/$pkgname-$_pkgver/src"
build() {
cd "$builddir"
@@ -42,11 +43,7 @@ package() {
install -m755 unison-text unison-fsmonitor "$pkgdir"/usr/bin
cd "$pkgdir"/usr/bin
ln -s unison-text unison
- ln -s unison "unison-${pkgver%.*}"
-
- cd "$srcdir"
- install -d "$pkgdir"/usr/share/doc/"$pkgname"
- install -m644 unison-"$pkgver"-manual.html "$pkgdir"/usr/share/doc/"$pkgname"
+ ln -s unison "unison-${_pkgver%.*}"
}
gui() {
@@ -59,7 +56,7 @@ gui() {
install -m755 unison-gtk2 "$subpkgdir"/usr/bin
}
-sha512sums="c8e7bd2b14edae31e7d08154cdc2dce8173546b6163b9e5f4f2b1c8255792a7645d8449da88d7acfcbf498746481d24d0a3936978969920530a15a16bcbc6024 unison-2.48.4.tar.gz
-b995712cda51d612bd81c89589d872099b3b9c90f7413268b24ab399a1eff7690200980514a834ee3d12bd3c89ef61bb8a29b3970c01433e0c4671d363a96b68 unison-2.48.4-manual.html
-27eaf4f347dc827dc14b338ef2be40d25507c6c9d65ecdc8f811ebe994f6e23577ad85fcc86b63d148b57844b24e6034061c869b641fbd3173532a26e0828803 fix_inotify_check.patch
-3ca783527ee4b5eacd060086a72987e479b2f04d795d6689c8357eb33635e91021b6cd8b926cb583a4ca3dd18373c8ce5b50ba44dd5fa18b2e2e78922cea3c9f marshalling.patch"
+sha512sums="658b37fd18d8dee517e88ad707f7e80c1731542a0e07e6a8d56e6598e38bcf405cdb8db224274bf9b3319ed87efc45057d1f79e6437c4ca53afe9cec4afe6c78 unison-2.48.15v4.tar.gz
+53ef0b9bd5632509cad69d60924da36836017574a59cd373aa44710c2d82b1329ab406753f430c98be8527428bd9a4847dde372dc5074781eb4a83de4e300d77 fix-inotify-check.patch
+cd8b9b6edc22c586f8f3fa566224c465a007b46b86766c25c2348f1a8eadb8faf28d6a8e4747611f8550f938ed52cb62de00cd9ca175e27b57cd81d6c286229a makefile-fix-clean.patch
+b7ffd449ff54f03f4f7ca11dfeb1cd4ebb757f60bd924797c4fb48e63bbc99188e353b53e240043e99d4915bf1c2ed54444bfe7c4b0393c5ad010b8ac16249e2 fix-for-lablgtk-2.18.6.patch"
diff --git a/community/unison/fix-for-lablgtk-2.18.6.patch b/community/unison/fix-for-lablgtk-2.18.6.patch
new file mode 100644
index 0000000000..888649a239
--- /dev/null
+++ b/community/unison/fix-for-lablgtk-2.18.6.patch
@@ -0,0 +1,20 @@
+Patch-Source: http://svnweb.mageia.org/packages/cauldron/unison/current/SOURCES/unison-2.51.2-fix-for-lablgtk-2.18.6.patch?view=markup&pathrev=1205069
+Upstream-Issue: https://github.com/bcpierce00/unison/issues/153
+
+--- a/uigtk2.ml
++++ b/uigtk2.ml
+@@ -89,12 +89,12 @@
+ (* This does not work with the current version of Lablgtk, due to a bug
+ let icon =
+ GdkPixbuf.from_data ~width:48 ~height:48 ~has_alpha:true
+- (Gpointer.region_of_string Pixmaps.icon_data)
++ (Gpointer.region_of_bytes Pixmaps.icon_data)
+ *)
+ let icon =
+ let p = GdkPixbuf.create ~width:48 ~height:48 ~has_alpha:true () in
+ Gpointer.blit
+- (Gpointer.region_of_string Pixmaps.icon_data) (GdkPixbuf.get_pixels p);
++ (Gpointer.region_of_bytes Pixmaps.icon_data) (GdkPixbuf.get_pixels p);
+ p
+
+ let leftPtrWatch =
diff --git a/community/unison/fix-inotify-check.patch b/community/unison/fix-inotify-check.patch
new file mode 100644
index 0000000000..54233079d0
--- /dev/null
+++ b/community/unison/fix-inotify-check.patch
@@ -0,0 +1,12 @@
+--- a/fsmonitor/linux/inotify_stubs.c
++++ b/fsmonitor/linux/inotify_stubs.c
+@@ -35,6 +35,9 @@
+ #define GLIBC_SUPPORT_INOTIFY 0
+ #endif
+
++/* Alpine linux supports inotify */
++#define GLIBC_SUPPORT_INOTIFY 1
++
+ #if GLIBC_SUPPORT_INOTIFY
+ #include <sys/inotify.h>
+ #else
diff --git a/community/unison/fix_inotify_check.patch b/community/unison/fix_inotify_check.patch
deleted file mode 100644
index 009ce789cc..0000000000
--- a/community/unison/fix_inotify_check.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff -ru a/fsmonitor/linux/inotify_stubs.c b/fsmonitor/linux/inotify_stubs.c
---- a/fsmonitor/linux/inotify_stubs.c 2016-05-23 18:40:05.000000000 +0200
-+++ b/fsmonitor/linux/inotify_stubs.c 2017-01-23 23:14:47.613834613 +0100
-@@ -35,6 +35,9 @@
- #define GLIBC_SUPPORT_INOTIFY 0
- #endif
-
-+/* Alpine linux supports inotify */
-+#define GLIBC_SUPPORT_INOTIFY 1
-+
- #if GLIBC_SUPPORT_INOTIFY
- #include <sys/inotify.h>
- #else
diff --git a/community/unison/makefile-fix-clean.patch b/community/unison/makefile-fix-clean.patch
new file mode 100644
index 0000000000..1b584d0f47
--- /dev/null
+++ b/community/unison/makefile-fix-clean.patch
@@ -0,0 +1,25 @@
+$(FSMONITOR) starts with a hyphen, so it's interpreted as an option.
+$(NAME) is empty, so -blob is interpreted as an option.
+
+--- a/fsmonitor/linux/Makefile
++++ b/fsmonitor/linux/Makefile
+@@ -26,4 +26,4 @@
+
+ clean::
+ rm -f $(DIR)/*.cm[iox] $(DIR)/*.o $(DIR)/*~
+- rm -f $(FSMONITOR)$(EXEC_EXT)
+\ No newline at end of file
++ rm -f -- $(FSMONITOR)$(EXEC_EXT)
+--- a/Makefile
++++ b/Makefile
+@@ -354,8 +354,8 @@
+ clean::
+ -$(RM) *.log *.aux *.log *.dvi *.out *.bak
+ -$(RM) -r obsolete
+- -$(RM) $(NAME) $(NAME).exe
+- -$(RM) $(NAME)-blob.o
++ -$(RM) -- $(NAME) $(NAME).exe
++ -$(RM) -- $(NAME)-blob.o
+
+ clean::
+ $(MAKE) -C ubase clean
diff --git a/community/unison/marshalling.patch b/community/unison/marshalling.patch
deleted file mode 100644
index 997b90b513..0000000000
--- a/community/unison/marshalling.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/remote.ml 2016-05-23 18:40:05.000000000 +0200
-+++ b/remote.ml 2017-03-23 11:33:24.784228112 +0100
-@@ -450,12 +450,7 @@
- let s = Bytearray.marshal data [Marshal.No_sharing] in
- let l = Bytearray.length s in
- ((s, 0, l) :: rem, l)),
-- (fun buf pos ->
-- try Bytearray.unmarshal buf pos
-- with Failure s -> raise (Util.Fatal (Printf.sprintf
--"Fatal error during unmarshaling (%s),
--possibly because client and server have been compiled with different\
--versions of the OCaml compiler." s)))
-+ (fun buf pos -> Bytearray.unmarshal buf pos)
-
- let makeMarshalingFunctions payloadMarshalingFunctions string =
- let (marshalPayload, unmarshalPayload) = payloadMarshalingFunctions in