aboutsummaryrefslogtreecommitdiffstats
path: root/community/virtualbox-guest-modules-hardened/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2017-11-20 15:07:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2017-11-20 15:30:24 +0000
commit371142fae2eaee3874375cf64fb5651dd149a7b2 (patch)
tree904b99a46c1248f5f1854e93a4aaa66dacd46a0a /community/virtualbox-guest-modules-hardened/APKBUILD
parent7806f26b4d52ee8d076150a3d9073645a58766b4 (diff)
downloadaports-371142fae2eaee3874375cf64fb5651dd149a7b2.tar.bz2
aports-371142fae2eaee3874375cf64fb5651dd149a7b2.tar.xz
community/virtualbox-guest-modules-hardened: upgrade to 5.1.30
Diffstat (limited to 'community/virtualbox-guest-modules-hardened/APKBUILD')
-rw-r--r--community/virtualbox-guest-modules-hardened/APKBUILD15
1 files changed, 7 insertions, 8 deletions
diff --git a/community/virtualbox-guest-modules-hardened/APKBUILD b/community/virtualbox-guest-modules-hardened/APKBUILD
index 5947b2e396..cc47b541e0 100644
--- a/community/virtualbox-guest-modules-hardened/APKBUILD
+++ b/community/virtualbox-guest-modules-hardened/APKBUILD
@@ -3,11 +3,11 @@
_flavor=${FLAVOR:-hardened}
_kpkg=linux-$_flavor
-_kver=4.9.60
+_kver=4.9.63
_kpkgrel=0
# when chaning _ver we *must* bump _mypkgrel
-_ver=5.1.26
+_ver=5.1.30
_mypkgrel=0
_name=virtualbox-guest-modules
@@ -47,12 +47,12 @@ prepare() {
die "please update _kpkgrel to $pkgrel"
fi
fi
- ) || return 1
+ )
cd "$builddir"
- default_prepare || return 1
+ default_prepare
"$builddir"/src/VBox/Additions/linux/export_modules \
- "$srcdir/vbox-kmod-$_ver.tar.gz" || return 1
+ "$srcdir/vbox-kmod-$_ver.tar.gz"
for i in $_abi_release $_abi_release_virthardened; do
mkdir -p "$srcdir/$i"
@@ -65,8 +65,7 @@ build() {
for i in $_abi_release $_abi_release_virthardened; do
cd "$srcdir/$i"
# Build Kernel Modules
- make KERN_DIR=/lib/modules/${i}/build \
- || return 1
+ make KERN_DIR=/lib/modules/${i}/build
done
}
@@ -90,6 +89,6 @@ _virthardened() {
"$subpkgdir"/lib/modules/
}
-sha512sums="680e9646a51a0a5923b3ded10007ee1c1e2a41c6d8a961d2b2540db6578bed2847154f4cac87e3cfe1118a62595b47c7df99da854f6c340e173b9eb8cacf2add VirtualBox-5.1.26.tar.bz2
+sha512sums="6c44d9593f4815644a484b306e621fe7eca224002f85d89c00f2470300f2c78dbfe50ffda61d2c2465df14ca77c70a2ab86f1a05116feeee9f5833857eb18dee VirtualBox-5.1.30.tar.bz2
bd934e9ed3d2324ef66e2539d2f3f6fab35a8858d670bba817b9cabfe66e85fe13a8594b35f4a8e639841f72fb0b8d12af38518ba25638da5ef338b259ab600b vboxguest-log-use-c99.patch
d069876f93e431833800c1d26ea77ae1dec40c840bb549cf519ceea93ee1ca89bcb262a13b00001503d19e596965d74a71a7f49be232ea892a82114d3ea4337c const-struct-kernel_param.patch"