aboutsummaryrefslogtreecommitdiffstats
path: root/community/vis
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-04-02 15:21:28 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-04-03 08:42:38 +0200
commit06bee5a224c344df0c1aa2865ea372ab2e5318ad (patch)
treecb68fcf14665b314b40dd0eb0aecf3694a5daf0e /community/vis
parent32897865725c39cdc8de63ae866734e0e6fcb68b (diff)
downloadaports-06bee5a224c344df0c1aa2865ea372ab2e5318ad.tar.bz2
aports-06bee5a224c344df0c1aa2865ea372ab2e5318ad.tar.xz
community/vis: move from testing
Diffstat (limited to 'community/vis')
-rw-r--r--community/vis/APKBUILD46
-rw-r--r--community/vis/fortify-source.patch16
2 files changed, 62 insertions, 0 deletions
diff --git a/community/vis/APKBUILD b/community/vis/APKBUILD
new file mode 100644
index 0000000000..d242750eb1
--- /dev/null
+++ b/community/vis/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
+pkgname=vis
+pkgver=0.3
+_testver=0.1
+pkgrel=1
+pkgdesc="A vim like text editor"
+url="https://github.com/martanne/vis"
+arch="all"
+license="ISC"
+depends="!outils-vis lua5.2-lpeg"
+depends_dev=""
+makedepends="libtermkey-dev ncurses-dev acl-dev lua5.2-dev"
+checkdepends="vim"
+install=""
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/martanne/$pkgname/archive/v$pkgver.tar.gz
+ $pkgname-test-$pkgver.tar.gz::https://github.com/martanne/$pkgname-test/archive/v$_testver.tar.gz
+ fortify-source.patch"
+
+_testdir="$srcdir"/$pkgname-test-$_testver
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --enable-lua \
+ --enable-acl
+ make
+}
+
+check() {
+ cp -r "$_testdir"/* "$builddir"/test/
+ make -C "$builddir" test
+}
+
+package() {
+ make -C "$builddir" \
+ DESTDIR="$pkgdir" \
+ install
+}
+
+sha512sums="e1ca009bd7569f22dacf7464791f9f4499695d15d6e38e1be491d39e7ebe0530de643be5c1e7647e9beb7969a17efab6545d3e719fe8cf311562e89d636bba62 vis-0.3.tar.gz
+433a67892f27eb01f3ea6224e1ded393cd949b4d60f7c14656fdd526c02d2b309f63d39887d8d7ba11cbad3e183ab3cd1a913ac40aa29eadb7fa700eb76424b6 vis-test-0.3.tar.gz
+53a2f70a67e4fdb7462904428bbd556f5452989ada746ec8d67b7a90aabbf806377ef7d66d760d0d74ab3101d4af2154b1a59403fce60b20ef11476242cba713 fortify-source.patch"
diff --git a/community/vis/fortify-source.patch b/community/vis/fortify-source.patch
new file mode 100644
index 0000000000..763c73e7ab
--- /dev/null
+++ b/community/vis/fortify-source.patch
@@ -0,0 +1,16 @@
+-D_FORTIFY_SOURCE=2 is enable in gcc by default on alpine. See the
+010_all_default-fortify-source.patch patch in main/gcc. Disabling
+it here silences a bunch of compiler warnings.
+
+diff -upr vis-0.2.orig/configure vis-0.2/configure
+--- vis-0.2.orig/configure 2016-04-06 23:36:44.232477390 +0200
++++ vis-0.2/configure 2016-04-06 23:36:59.705671155 +0200
+@@ -199,7 +199,7 @@ tryflag CFLAGS_TRY -Werror=unused-com
+ tryldflag LDFLAGS_TRY -Werror=unknown-warning-option
+ tryldflag LDFLAGS_TRY -Werror=unused-command-line-argument
+
+-CFLAGS_STD="-std=c99 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -DNDEBUG -D_FORTIFY_SOURCE=2"
++CFLAGS_STD="-std=c99 -D_POSIX_C_SOURCE=200809L -D_XOPEN_SOURCE=700 -DNDEBUG"
+ LDFLAGS_STD="-lc"
+
+ OS=$(uname)