aboutsummaryrefslogtreecommitdiffstats
path: root/community/waylandpp
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-08-10 19:26:47 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-08-10 14:50:36 -0300
commitc2cf326d1c321124c0e8971d898c06776d358006 (patch)
tree5e4744f839dd3967ab76b70160e40793a7d45749 /community/waylandpp
parent4cd10d92c31a772223938ca214fc055138eaed80 (diff)
downloadaports-c2cf326d1c321124c0e8971d898c06776d358006.tar.bz2
aports-c2cf326d1c321124c0e8971d898c06776d358006.tar.xz
community/waylandpp: move from testing
Diffstat (limited to 'community/waylandpp')
-rw-r--r--community/waylandpp/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/waylandpp/APKBUILD b/community/waylandpp/APKBUILD
new file mode 100644
index 0000000000..bef5a5e740
--- /dev/null
+++ b/community/waylandpp/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=waylandpp
+pkgver=0.2.5
+pkgrel=0
+arch="all"
+url="https://github.com/NilsBrause/waylandpp"
+pkgdesc="Wayland C++ bindings"
+license="MIT AND GPL-3.0-or-later"
+depends_dev="pugixml-dev wayland-dev mesa-dev"
+makedepends="$depends_dev cmake doxygen graphviz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nilsbrause/$pkgname/archive/$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="a8c80282022b2ede3c3d0f5516e236aedaf3ef685565da8c61214fe37eda139bf152093eb29960be1889798eef5631b9d68a5e832c10cf1160c4a90f45eccb6e waylandpp-0.2.5.tar.gz"