aboutsummaryrefslogtreecommitdiffstats
path: root/community/webkit2gtk
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-09-10 05:37:35 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-10 05:38:11 +0000
commit8c4e68d68e7f75ad3ef6b9ce1f938d1fae1ccc44 (patch)
treeaa0bccd03948050828b48ace475551a9f299205a /community/webkit2gtk
parent91ba9be2ce5c4fd00cdc91795c018b8429a67663 (diff)
downloadaports-8c4e68d68e7f75ad3ef6b9ce1f938d1fae1ccc44.tar.bz2
aports-8c4e68d68e7f75ad3ef6b9ce1f938d1fae1ccc44.tar.xz
community/webkit2gtk: upgrade to 2.26.0
Diffstat (limited to 'community/webkit2gtk')
-rw-r--r--community/webkit2gtk/APKBUILD11
-rw-r--r--community/webkit2gtk/musl-fixes.patch41
2 files changed, 27 insertions, 25 deletions
diff --git a/community/webkit2gtk/APKBUILD b/community/webkit2gtk/APKBUILD
index a4adf9d52c..c1f5be81b0 100644
--- a/community/webkit2gtk/APKBUILD
+++ b/community/webkit2gtk/APKBUILD
@@ -3,12 +3,13 @@
# Contributor: Jiri Horner <laeqten@gmail.com>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=webkit2gtk
-pkgver=2.24.4
-pkgrel=1
+pkgver=2.26.0
+pkgrel=0
pkgdesc="Portable web rendering engine WebKit for GTK+"
url="https://webkitgtk.org/"
arch="all"
license="LGPL-2.0-or-later AND BSD-2-Clause"
+depends="bubblewrap xdg-dbus-proxy"
makedepends="
bison
cmake
@@ -28,6 +29,7 @@ makedepends="
libjpeg-turbo-dev
libnotify-dev
libpng-dev
+ libseccomp-dev
libsecret-dev
libsoup-dev
libwebp-dev
@@ -147,6 +149,7 @@ build() {
-DENABLE_PLUGIN_PROCESS_GTK2=OFF \
-DENABLE_SAMPLING_PROFILER=OFF \
-DENABLE_MINIBROWSER=ON \
+ -DUSE_WPE_RENDERER=OFF \
-DUSE_WOFF2=ON \
-DCMAKE_CXX_FLAGS="$CXXFLAGS" \
$_archopt \
@@ -166,7 +169,7 @@ package() {
paxmark -m "$pkgdir"/usr/libexec/webkit2gtk-4.0/WebKitWebProcess
}
-sha512sums="1d713955a735ae2e2229beea7bda7f518a6247c6aa7f5753aeb5b5c6395339d451d0d146f7188e7ba65cb82ea5a74a5e73e956fe59d5f5f97659a44af33df112 webkitgtk-2.24.4.tar.xz
+sha512sums="0af18d56c441b36a30dd0e5b16315ae35fad309ad1b940bed27fb615c228dbee6c2992c89ab8b76bbe924ee18f5fc11598fa882397ae29dc00ebddf4d301c228 webkitgtk-2.26.0.tar.xz
e1537b9937af1cb936669d405993a52204cb9968b8b3161cb12a3f3f1343c260088c9490fcd7a7deeab6dbabdb5f7ce7e6cb2f857b9f0a4205aba6db2b11fb20 fix-fast-memory-disabled.patch
-d0d5e37822644cab071e33d325affd1ce5948b414f6f54d695e6b4a7bffadecd25c0df6dc1cb63e70127499f5a8da43b02286a3518b2488b5da32c622df45d97 musl-fixes.patch
+dfd5352272c02eeaae31af80eceb8158b84a92c15e4b3966912a2acdecf7e1aa1f6bf78992b88b344393b57724489e3452d57b7ab4ef7c9f2ef5acd10cb07b33 musl-fixes.patch
c517c012f5630ef6be5be7d9592c5e042a070f849a141859edefa7984acb98dbd0d718fe6613cd35ba3b7d8530beebcc7408fd077cd914ed335c5e524e9e746a fix-openjpeg.patch"
diff --git a/community/webkit2gtk/musl-fixes.patch b/community/webkit2gtk/musl-fixes.patch
index c829f19fe7..8cd73b3944 100644
--- a/community/webkit2gtk/musl-fixes.patch
+++ b/community/webkit2gtk/musl-fixes.patch
@@ -62,27 +62,6 @@
v(bool, crashIfCantAllocateJITMemory, false, Normal, nullptr) \
v(unsigned, jitMemoryReservationSize, 0, Normal, "Set this number to change the executable allocation size in ExecutableAllocatorFixedVMPool. (In bytes.)") \
---- a/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
-+++ b/Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
-@@ -836,7 +836,7 @@ int yydebug;
- #if YYERROR_VERBOSE
-
- # ifndef yystrlen
--# if defined __GLIBC__ && defined _STRING_H
-+# if defined __linux__ && defined _STRING_H
- # define yystrlen strlen
- # else
- /* Return the length of YYSTR. */
-@@ -852,7 +852,7 @@ yystrlen (const char *yystr)
- # endif
-
- # ifndef yystpcpy
--# if defined __GLIBC__ && defined _STRING_H && defined _GNU_SOURCE
-+# if defined __linux__ && defined _STRING_H && defined _GNU_SOURCE
- # define yystpcpy stpcpy
- # else
- /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
-
--- a/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
+++ b/Source/ThirdParty/ANGLE/src/compiler/translator/glslang_tab.cpp
@@ -1975,7 +1975,7 @@ int yydebug;
@@ -135,3 +114,23 @@
# define yystpcpy stpcpy
# else
/* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in
+--- ./Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp.orig
++++ ./Source/ThirdParty/ANGLE/src/compiler/preprocessor/ExpressionParser.cpp
+@@ -728,7 +728,7 @@
+ #if YYERROR_VERBOSE
+
+ # ifndef yystrlen
+-# if defined __GLIBC__ && defined _STRING_H
++# if defined __linux__ && defined _STRING_H
+ # define yystrlen strlen
+ # else
+ /* Return the length of YYSTR. */
+@@ -743,7 +743,7 @@
+ # endif
+
+ # ifndef yystpcpy
+-# if defined __GLIBC__ && defined _STRING_H && defined _GNU_SOURCE
++# if defined __linux__ && defined _STRING_H && defined _GNU_SOURCE
+ # define yystpcpy stpcpy
+ # else
+ /* Copy YYSRC to YYDEST, returning the address of the terminating '\0' in