aboutsummaryrefslogtreecommitdiffstats
path: root/community/webkitgtk
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@gmail.com>2016-08-29 16:24:15 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2016-08-29 16:24:21 +0000
commitd28f27dbd511685428d8b7af191ac1e9de7c861a (patch)
treebe53bbd1afde95b155b06543338ac8f16ff6fd97 /community/webkitgtk
parent96578ce2a4178a60acd118f53a254c24f39c4293 (diff)
downloadaports-d28f27dbd511685428d8b7af191ac1e9de7c861a.tar.bz2
aports-d28f27dbd511685428d8b7af191ac1e9de7c861a.tar.xz
community/webkitgtk: fix build on aarch64
Diffstat (limited to 'community/webkitgtk')
-rw-r--r--community/webkitgtk/APKBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/webkitgtk/APKBUILD b/community/webkitgtk/APKBUILD
index 026816ab63..f7e3dfa87d 100644
--- a/community/webkitgtk/APKBUILD
+++ b/community/webkitgtk/APKBUILD
@@ -72,6 +72,16 @@ prepare() {
_build() {
local _ver=$1
+
+ # disable jit on aarch64
+ if [ "$CARCH" = "aarch64" ]; then
+ local _conf="--disable-jit"
+ export CXXFLAGS="$CXXFLAGS -DENABLE_YARR_JIT=0"
+ fi
+
+ # Workaround crashes with gcc 6.1
+ export CXXFLAGS="$CXXFLAGS -fno-delete-null-pointer-checks"
+
shift
../configure $@\
--build=$CBUILD \
@@ -85,6 +95,7 @@ _build() {
--enable-introspection \
--with-gtk=$_ver \
--disable-webkit2 \
+ $_conf \
|| return 1
# fight overlinking