aboutsummaryrefslogtreecommitdiffstats
path: root/community/websocket++/APKBUILD
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 16:19:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-08 20:21:13 +0000
commit59ab6aab54776f9121959517ed32f5b49e165b3b (patch)
treef960e5468bd043cd460fab59d02757a9124797c9 /community/websocket++/APKBUILD
parent283611e8735576b25083714dc24c6bc10a988dee (diff)
downloadaports-59ab6aab54776f9121959517ed32f5b49e165b3b.tar.bz2
aports-59ab6aab54776f9121959517ed32f5b49e165b3b.tar.xz
community/websocket++: move from main
Diffstat (limited to 'community/websocket++/APKBUILD')
-rw-r--r--community/websocket++/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/websocket++/APKBUILD b/community/websocket++/APKBUILD
new file mode 100644
index 0000000000..4d0bd93d43
--- /dev/null
+++ b/community/websocket++/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=websocket++
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="C++/Boost Asio based websocket client/server library"
+url="https://github.com/zaphoyd/websocketpp"
+arch="all"
+license="BSD-3-Clause"
+makedepends="$depends_dev cmake"
+source="$pkgname-$pkgver.tar.gz::https://github.com/zaphoyd/websocketpp/archive/$pkgver.tar.gz"
+builddir="$srcdir"/websocketpp-$pkgver
+
+build() {
+ if [ "$CBUILD" != "$CHOST" ]; then
+ CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
+ fi
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=None \
+ -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
+ -DCMAKE_C_FLAGS="$CFLAGS" \
+ $CMAKE_CROSSOPTS
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="35e0261ed0285acf77d300768819bd380197de8acdf68223e2d7598481b9bfd69cb1653b435139771b1db6c16530c8d8cf9a887a8a6bba3fea126d0da4dbc13c websocket++-0.8.1.tar.gz"