aboutsummaryrefslogtreecommitdiffstats
path: root/community/weston
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-08 08:44:30 +0100
committerKevin Daudt <kdaudt@alpinelinux.org>2020-03-08 12:48:41 +0100
commitbe1f4b0ac6b4feefb37281846cf42c5de5a56cc4 (patch)
tree6479802541c03b475ec78a0f13d8fde58b3cc43c /community/weston
parent1688d8db03c790b12d4acdeac36e537ffff9dd6a (diff)
downloadaports-be1f4b0ac6b4feefb37281846cf42c5de5a56cc4.tar.bz2
aports-be1f4b0ac6b4feefb37281846cf42c5de5a56cc4.tar.xz
community/weston: disable pipewire support for now
It's not compatible with pipewire-0.3
Diffstat (limited to 'community/weston')
-rw-r--r--community/weston/APKBUILD5
-rw-r--r--community/weston/pipewire-03.patch13
2 files changed, 16 insertions, 2 deletions
diff --git a/community/weston/APKBUILD b/community/weston/APKBUILD
index 94ae7e3f8f..784b12983b 100644
--- a/community/weston/APKBUILD
+++ b/community/weston/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=weston
pkgver=8.0.0
-pkgrel=1
+pkgrel=2
_libname=lib$pkgname
_libdir=$_libname-${pkgver%%.*}
pkgdesc="The reference Wayland server"
@@ -14,7 +14,7 @@ makedepends="wayland-protocols libxkbcommon-dev xkeyboard-config
pango-dev colord-dev libwebp-dev libva-dev dbus-dev
linux-pam-dev wayland-dev libevdev-dev libjpeg-turbo-dev
freerdp-dev lcms2-dev gstreamer-dev gst-plugins-base-dev meson
- elogind-dev pipewire-dev
+ elogind-dev
"
_cms="cms-colord cms-static"
_shell="shell-desktop shell-fullscreen shell-ivi"
@@ -43,6 +43,7 @@ build() {
-Dlauncher-logind=true \
-Dsystemd=false \
-Dsimple-dmabuf-drm=auto \
+ -Dpipewire=false \
build
ninja -C build
}
diff --git a/community/weston/pipewire-03.patch b/community/weston/pipewire-03.patch
new file mode 100644
index 0000000000..6a4dc6908a
--- /dev/null
+++ b/community/weston/pipewire-03.patch
@@ -0,0 +1,13 @@
+diff --git a/pipewire/meson.build b/pipewire/meson.build
+index 67db61f..56109b1 100644
+--- a/pipewire/meson.build
++++ b/pipewire/meson.build
+@@ -6,7 +6,7 @@ if get_option('pipewire')
+ endif
+
+ depnames = [
+- 'libpipewire-0.2', 'libspa-0.1'
++ 'libpipewire-0.3', 'libspa-0.2'
+ ]
+ deps_pipewire = [ dep_libweston_private ]
+ foreach depname : depnames