aboutsummaryrefslogtreecommitdiffstats
path: root/community/wrk/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2019-05-10 20:47:02 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-11 07:13:00 +0000
commit6c8fd290fb2881568ee385d4e4732f52fd772a33 (patch)
tree42412658ce43fcd55dcafe904060197efb99b328 /community/wrk/APKBUILD
parentdc95667bf929242d02441ec95d74fc38478a0ae3 (diff)
downloadaports-6c8fd290fb2881568ee385d4e4732f52fd772a33.tar.bz2
aports-6c8fd290fb2881568ee385d4e4732f52fd772a33.tar.xz
community/wrk: upgrade to 4.1.0
Diffstat (limited to 'community/wrk/APKBUILD')
-rw-r--r--community/wrk/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/wrk/APKBUILD b/community/wrk/APKBUILD
index 6a75799277..457f7db589 100644
--- a/community/wrk/APKBUILD
+++ b/community/wrk/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=wrk
-pkgver=4.0.2
+pkgver=4.1.0
pkgrel=0
pkgdesc="wrk is a modern HTTP benchmarking tool"
url="https://github.com/wg/wrk"
@@ -12,7 +12,7 @@ license="Apache-2.0"
depends=""
depends_dev=""
options="!check" # upstream does not provide tests
-makedepends="libressl-dev perl-dev"
+makedepends="openssl-dev perl-dev linux-headers luajit-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/wg/wrk/archive/$pkgver.tar.gz"
builddir="$srcdir"/$pkgname-$pkgver
@@ -21,18 +21,22 @@ build() {
cd "$builddir"
# see https://github.com/wg/wrk/issues/310
touch buildinf.h
- make -j1 -C "$builddir"
+ make -j1 -C "$builddir" \
+ WITH_OPENSSL=/usr \
+ WITH_LUAJIT=/usr CFLAGS+=$(pkg-config --cflags luajit)
}
package() {
cd "$builddir"
- mkdir -p $pkgdir/usr/bin
- mkdir -p $pkgdir/usr/share/doc/$pkgname/scripts
+ mkdir -p "$pkgdir"/usr/bin \
+ "$pkgdir"/usr/share/licenses/$pkgname \
+ "$pkgdir"/usr/share/doc/$pkgname/scripts
+
install -m755 -D $pkgname "$pkgdir"/usr/bin/$pkgname
- install -m644 -D README "$pkgdir"/usr/share/doc/$pkgname/
- install -m644 -D LICENSE "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 -D README.md "$pkgdir"/usr/share/doc/$pkgname/
+ install -m644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/
install -m644 -D NOTICE "$pkgdir"/usr/share/doc/$pkgname/
install -m755 -D scripts/* "$pkgdir"/usr/share/doc/$pkgname/scripts/
}
-sha512sums="4279cf7136e2919779be3f61f462136a7a5288eac481104b844193682a8fc554581fd3942624d0be9317a3e82c82497927a124b9b4dbdf455e30d3f0cad1fdea wrk-4.0.2.tar.gz"
+sha512sums="2c8d05f8e40c3a6234bc1c2862157764532a39046860210fe512c260c2b940e1e3120b831d0721c936c7bca474574600cda1f4c949b53738199d98102e32cb1a wrk-4.1.0.tar.gz"