aboutsummaryrefslogtreecommitdiffstats
path: root/community/wt
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-24 23:29:09 -0300
committerTBK <tbk@jjtc.eu>2019-05-25 17:03:26 +0200
commite263d3098b4cdd63002ca85be337136a01517af6 (patch)
treee5ed2f10a9331b828984dce9ce9193269c477c9f /community/wt
parent8ed4689a3214b15f6c6529015163cc45933d19a2 (diff)
downloadaports-e263d3098b4cdd63002ca85be337136a01517af6.tar.bz2
aports-e263d3098b4cdd63002ca85be337136a01517af6.tar.xz
community/wt: modernize, fix license
Closes: GH-8044
Diffstat (limited to 'community/wt')
-rw-r--r--community/wt/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/community/wt/APKBUILD b/community/wt/APKBUILD
index 129a91055f..4ae3065505 100644
--- a/community/wt/APKBUILD
+++ b/community/wt/APKBUILD
@@ -2,24 +2,21 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=wt
pkgver=4.0.5
-pkgrel=2
+pkgrel=3
pkgdesc="A C++ library and application server for developing and deploying web applications"
url="https://www.webtoolkit.eu"
arch="all"
-license="GPL"
-depends=""
+license="GPL-2.0-or-later WITH openssl-exception"
depends_dev="zlib-dev boost-dev sqlite-dev mesa-dev glu-dev graphicsmagick-dev
- openssl-dev pango-dev sqlite-dev fcgi-dev postgresql-dev qt5-qtbase-dev libharu-dev"
+ openssl-dev pango-dev fcgi-dev postgresql-dev qt5-qtbase-dev libharu-dev"
makedepends="$depends_dev cmake boost"
pkggroups="wt"
pkgusers="wt"
options="!check"
subpackages="$pkgname-dev"
source="$pkgname-$pkgver.tar.gz::https://github.com/kdeforche/$pkgname/archive/$pkgver.tar.gz"
-builddir="$srcdir"/$pkgname-$pkgver
build() {
- cd "$builddir"
mkdir -p build && cd build
CXXFLAGS="-fpermissive" \
cmake \