aboutsummaryrefslogtreecommitdiffstats
path: root/community/x265
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-25 13:19:38 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-25 14:25:00 +0000
commit693e5b185fa7dcaeca67a070ff4f6e138542ddae (patch)
tree25cd75ef19e1a9149df258abb20b2adbac34337b /community/x265
parent5dec8e1acbfb62e8d068c5601cba7451c8e4dd8b (diff)
downloadaports-693e5b185fa7dcaeca67a070ff4f6e138542ddae.tar.bz2
aports-693e5b185fa7dcaeca67a070ff4f6e138542ddae.tar.xz
community/x265: move from main
Diffstat (limited to 'community/x265')
-rw-r--r--community/x265/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/x265/APKBUILD b/community/x265/APKBUILD
new file mode 100644
index 0000000000..c14ff616b0
--- /dev/null
+++ b/community/x265/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Carlo Landmeter <clandmeter@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=x265
+pkgver=2.8
+pkgrel=0
+pkgdesc="Open Source H265/HEVC video encoder"
+url="http://x265.org"
+arch="all"
+license="GPL-2.0-or-later"
+makedepends="cmake nasm"
+subpackages="$pkgname-dev $pkgname-libs"
+source="$pkgname-$pkgver.tar.gz::https://bitbucket.org/multicoreware/$pkgname/downloads/${pkgname}_${pkgver}.tar.gz"
+builddir="$srcdir/${pkgname}_$pkgver"
+
+build() {
+ cd "$builddir"/build/linux
+
+ # It has textrel on x86 so we disable asm.
+ local cmake_opts=""
+ case "$CARCH" in
+ x86) cmake_opts="-DENABLE_ASSEMBLY=OFF";;
+ ppc*) cmake_opts="-DENABLE_ALTIVEC=OFF -DCPU_POWER8=OFF";;
+ esac
+
+ cmake \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_VERBOSE_MAKEFILE=ON \
+ $cmake_opts \
+ ../../source
+ make
+}
+
+check() {
+ cd "$builddir"/build/linux
+
+ ./x265 --version
+}
+
+package() {
+ cd "$builddir"/build/linux
+
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="c2a8eaec64aa022badcbcd2a96304a9abd9d08489300b6a9c4c9d76066f3d9848e6948238c84ae16ea91bff0b2fac528a67ee29950d94dcd0ea7c0e9e7baa714 x265-2.8.tar.gz"