aboutsummaryrefslogtreecommitdiffstats
path: root/community/xapian-core
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2017-08-18 16:01:26 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2017-08-18 17:43:19 +0200
commita6710a9157152319951686889f97127ecf5370d5 (patch)
tree860e3efe045868ec04990ab0df65921bfe6f59a0 /community/xapian-core
parentce940d2bc5682e7ca1614a82aaa7a58177d3e93e (diff)
downloadaports-a6710a9157152319951686889f97127ecf5370d5.tar.bz2
aports-a6710a9157152319951686889f97127ecf5370d5.tar.xz
community/xapian-core: modernize APKBUILD
Diffstat (limited to 'community/xapian-core')
-rw-r--r--community/xapian-core/APKBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/community/xapian-core/APKBUILD b/community/xapian-core/APKBUILD
index 4c6781a185..2af54f2526 100644
--- a/community/xapian-core/APKBUILD
+++ b/community/xapian-core/APKBUILD
@@ -14,18 +14,23 @@ install=""
subpackages="$pkgname-dev $pkgname-doc libxapian"
source="http://oligarchy.co.uk/xapian/$pkgver/$pkgname-$pkgver.tar.xz
timeval-t.patch"
-
builddir="$srcdir"/$pkgname-$pkgver
build() {
cd "$builddir"
- ./configure --prefix=/usr || return 1
- make || return 1
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
libxapian() {