aboutsummaryrefslogtreecommitdiffstats
path: root/community/xapian-core
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-07-12 12:50:55 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-07-12 12:50:55 +0000
commitb6a54da9928a0712221a5f09ad9d5d3b5a6e3b46 (patch)
treeca17ef03e134a3d7f04e372db28771d8bc3f2540 /community/xapian-core
parent24c8e686f48dfeaf865563e81e4dbb4c1dcd991a (diff)
downloadaports-b6a54da9928a0712221a5f09ad9d5d3b5a6e3b46.tar.bz2
aports-b6a54da9928a0712221a5f09ad9d5d3b5a6e3b46.tar.xz
community/xapian-core: moved from main
Diffstat (limited to 'community/xapian-core')
-rw-r--r--community/xapian-core/APKBUILD53
-rw-r--r--community/xapian-core/timeval-t.patch12
2 files changed, 65 insertions, 0 deletions
diff --git a/community/xapian-core/APKBUILD b/community/xapian-core/APKBUILD
new file mode 100644
index 0000000000..8fa478a827
--- /dev/null
+++ b/community/xapian-core/APKBUILD
@@ -0,0 +1,53 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=xapian-core
+pkgver=1.4.0
+pkgrel=0
+pkgdesc="Open source search engine library"
+url="http://www.xapian.org/"
+arch="all"
+license="GPL2+"
+depends=""
+depends_dev="zlib-dev util-linux-dev"
+makedepends="$depends_dev libtool"
+install=""
+subpackages="$pkgname-dev $pkgname-doc libxapian"
+source="http://oligarchy.co.uk/xapian/$pkgver/$pkgname-$pkgver.tar.xz
+ timeval-t.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libxapian() {
+ arch="all"
+ cd "$_builddir"
+ pkgdesc="Xapian search engine library"
+ install -d "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/$subpkgname* "$subpkgdir"/usr/lib
+}
+
+md5sums="5308261e78337604bd8f845dd6b4aafc xapian-core-1.4.0.tar.xz
+689e6f6a15c61a229c558cbf91a656c1 timeval-t.patch"
+sha256sums="10584f57112aa5e9c0e8a89e251aecbf7c582097638bfee79c1fe39a8b6a6477 xapian-core-1.4.0.tar.xz
+3f28d677d08a1b75695ac7a010299762952043d04e14b52d352dda1c235c3427 timeval-t.patch"
+sha512sums="e37868e80187718995fd5b0f92a47c801b76c7bef129e01928d1de925b5f655ffe7c6907218809469ad4b89bf81c67ce9c9b5cc0646f2b8d629d6afd629a621e xapian-core-1.4.0.tar.xz
+639c0ecd75be0627d334628b5adf581a7da92c4f86dfb86a92669368ff8a874d4bf4e344b8f3b1276d22d126d2bc44c8ab727e39e1c29c0358fe7bbc8aa8050d timeval-t.patch"
diff --git a/community/xapian-core/timeval-t.patch b/community/xapian-core/timeval-t.patch
new file mode 100644
index 0000000000..b1fa7f71bb
--- /dev/null
+++ b/community/xapian-core/timeval-t.patch
@@ -0,0 +1,12 @@
+diff --git a/common/socket_utils.cc b/common/socket_utils.cc
+index 99a4a23..f7a872b 100644
+--- a/common/socket_utils.cc
++++ b/common/socket_utils.cc
+@@ -23,6 +23,7 @@
+
+ #include <cmath>
+ #include <limits>
++#include <sys/time.h>
+
+ using namespace std;
+