aboutsummaryrefslogtreecommitdiffstats
path: root/community/xbacklight
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:22:41 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:47:48 -0300
commite540c6e7b888bc70982efd8c20b3caf05fce976b (patch)
tree27f0bcafc7f5054ecca111795eb3325aef705586 /community/xbacklight
parentd862df802c7a226c823f7da0d9920f43548c1be3 (diff)
downloadaports-e540c6e7b888bc70982efd8c20b3caf05fce976b.tar.bz2
aports-e540c6e7b888bc70982efd8c20b3caf05fce976b.tar.xz
community/xbacklight: move from main
Diffstat (limited to 'community/xbacklight')
-rw-r--r--community/xbacklight/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/community/xbacklight/APKBUILD b/community/xbacklight/APKBUILD
new file mode 100644
index 0000000000..ed25418a9b
--- /dev/null
+++ b/community/xbacklight/APKBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xbacklight
+pkgver=1.2.3
+pkgrel=0
+pkgdesc="Adjusts backlight level using the RandR 1.2 output property"
+url="http://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+makedepends="libx11-dev libxrandr-dev xcb-util-wm-dev"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="717c87ce24634892fc4ac54fc59dcc0a5bc8f206aaf1d13410f95f7e4fe6e3dbc7ff8d951bcd8ea8c5e955357a00fea6ceadd4559e60b1a632e40f71290e12c7 xbacklight-1.2.3.tar.bz2"