aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-notifyd
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-05-24 00:26:52 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-05-24 00:24:55 +0200
commit241aa99917638184158957c247b985f914335ab5 (patch)
treeb45f7edf644426e9c44b3617452fbdb791b496fb /community/xfce4-notifyd
parent0c0f6f5c48a4fc84c75aa7ac7890cf23f35427a4 (diff)
downloadaports-241aa99917638184158957c247b985f914335ab5.tar.bz2
aports-241aa99917638184158957c247b985f914335ab5.tar.xz
community/xfce4-notifyd: fix url, pkgdesc and modernize abuild
Diffstat (limited to 'community/xfce4-notifyd')
-rw-r--r--community/xfce4-notifyd/APKBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/community/xfce4-notifyd/APKBUILD b/community/xfce4-notifyd/APKBUILD
index fe16ee6e7e..0d7477b3eb 100644
--- a/community/xfce4-notifyd/APKBUILD
+++ b/community/xfce4-notifyd/APKBUILD
@@ -1,26 +1,20 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xfce4-notifyd
pkgver=0.3.6
-pkgrel=0
-pkgdesc="notification daemon for the xfce desktop"
-url="http://spuriousinterrupt.org/projects/xfce4-notifyd"
+pkgrel=1
+pkgdesc="Notification daemon for the xfce desktop"
+url="https://docs.xfce.org/apps/notifyd/"
arch="all"
license="GPL-2.0"
depends="hicolor-icon-theme"
makedepends="gtk+-dev libxfce4util libxfce4ui-dev libsexy-dev xfconf-dev
dbus-glib-dev libglade-dev libnotify-dev"
-install=
subpackages="$pkgname-lang $pkgname-doc"
-source="http://archive.xfce.org/src/apps/xfce4-notifyd/${pkgver%.*}/xfce4-notifyd-$pkgver.tar.bz2"
-
-_builddir="$srcdir"/$pkgname-$pkgver
-
-prepare() {
- cd "$_builddir"
-}
+source="http://archive.xfce.org/src/apps/$pkgname/${pkgver%.*}/$pkgname-$pkgver.tar.bz2"
+builddir="$srcdir/$pkgname-$pkgver"
build () {
- cd "$_builddir"
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -28,14 +22,13 @@ build () {
--sysconfdir=/etc \
--libexecdir=/usr/lib/xfce4 \
--localstatedir=/var \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
}
sha512sums="96067de2e08e29c8e6285796bc4b23087f97286e28adfb485dc20f449ae32e10c8fb743f42585e0e6cda82d713eb6da3cc1d94920eb170b7cfa1e687ffcb3ddf xfce4-notifyd-0.3.6.tar.bz2"