aboutsummaryrefslogtreecommitdiffstats
path: root/community/xfce4-notifyd
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-23 19:44:46 +0000
commit27d1e194717b1696b3169ad43df027876247b91a (patch)
tree8416dc507bc2aed5f47588d345abe1ef22a6c60f /community/xfce4-notifyd
parent0090cfe5db52bd764631d9b1d55e6e74c7cf2ae8 (diff)
downloadaports-27d1e194717b1696b3169ad43df027876247b91a.tar.bz2
aports-27d1e194717b1696b3169ad43df027876247b91a.tar.xz
main/{xfce*} => community/
Move everything xfce to community
Diffstat (limited to 'community/xfce4-notifyd')
-rw-r--r--community/xfce4-notifyd/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/xfce4-notifyd/APKBUILD b/community/xfce4-notifyd/APKBUILD
new file mode 100644
index 0000000000..fe16ee6e7e
--- /dev/null
+++ b/community/xfce4-notifyd/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xfce4-notifyd
+pkgver=0.3.6
+pkgrel=0
+pkgdesc="notification daemon for the xfce desktop"
+url="http://spuriousinterrupt.org/projects/xfce4-notifyd"
+arch="all"
+license="GPL-2.0"
+depends="hicolor-icon-theme"
+makedepends="gtk+-dev libxfce4util libxfce4ui-dev libsexy-dev xfconf-dev
+ dbus-glib-dev libglade-dev libnotify-dev"
+install=
+subpackages="$pkgname-lang $pkgname-doc"
+source="http://archive.xfce.org/src/apps/xfce4-notifyd/${pkgver%.*}/xfce4-notifyd-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+
+prepare() {
+ cd "$_builddir"
+}
+
+build () {
+ cd "$_builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --libexecdir=/usr/lib/xfce4 \
+ --localstatedir=/var \
+ --disable-static \
+ || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+sha512sums="96067de2e08e29c8e6285796bc4b23087f97286e28adfb485dc20f449ae32e10c8fb743f42585e0e6cda82d713eb6da3cc1d94920eb170b7cfa1e687ffcb3ddf xfce4-notifyd-0.3.6.tar.bz2"