aboutsummaryrefslogtreecommitdiffstats
path: root/community/xpra
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-23 19:07:53 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-23 23:10:39 +0100
commit48c23043e7eac32c6eb50228c5707282cd656c7b (patch)
treee01ff365d270000379a624d5c61d460447768adb /community/xpra
parent7bfc20a03f18028dfacfe0b4e66273e105374fea (diff)
downloadaports-48c23043e7eac32c6eb50228c5707282cd656c7b.tar.bz2
aports-48c23043e7eac32c6eb50228c5707282cd656c7b.tar.xz
community/xpra: upgrade to 3.0.3
Diffstat (limited to 'community/xpra')
-rw-r--r--community/xpra/APKBUILD11
-rw-r--r--community/xpra/avoid-x86-only-compile-flags.patch17
2 files changed, 4 insertions, 24 deletions
diff --git a/community/xpra/APKBUILD b/community/xpra/APKBUILD
index 0d6ff69c7c..b3bf84a88e 100644
--- a/community/xpra/APKBUILD
+++ b/community/xpra/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Stuart Cardall <developer@it-offshore.co.uk>
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=xpra
-pkgver=3.0.2
-pkgrel=2
+pkgver=3.0.3
+pkgrel=0
pkgdesc="Xpra is 'screen for X' & allows you to run X programs, usually on a remote host over SSH or encrypted tcp"
url="https://xpra.org"
arch="all"
@@ -64,9 +64,7 @@ makedepends="
"
subpackages="$pkgname-openrc $pkgname-doc $pkgname-tests::noarch $pkgname-webclient::noarch"
options="!check"
-source="https://xpra.org/src/xpra-$pkgver.tar.xz
- avoid-x86-only-compile-flags.patch
- "
+source="https://xpra.org/src/xpra-$pkgver.tar.xz"
build() {
# https://www.xpra.org/trac/ticket/1080
@@ -102,5 +100,4 @@ webclient() {
cp -rf usr/share/xpra/www "$subpkgdir"/usr/share/xpra/
}
-sha512sums="115f606ff5886d99a906f318cb1a7a4a86e80ebf23e4336e67938267d92ef624de577cc8fc06c6ce541b7c44a0cef58d930b5928f32e24dfc67c72127c7b623c xpra-3.0.2.tar.xz
-249028f61d20ee8c8378f9cebe13c6e0f288c7635eb66be44e20fef9af023266e1266a893cd4ce56dd7714ac1eb851be59cea5733fb8fc787e4b92e4f10c2a16 avoid-x86-only-compile-flags.patch"
+sha512sums="0d13a2685b22e0c90450c0dddeef0663255c6d9e15e347e960c9ac7857cd2081b15d1fdc29b816b5cfdf1f000375be34510fe25be23af3f3b63a8a25d1b31003 xpra-3.0.3.tar.xz"
diff --git a/community/xpra/avoid-x86-only-compile-flags.patch b/community/xpra/avoid-x86-only-compile-flags.patch
deleted file mode 100644
index 0f6c5871aa..0000000000
--- a/community/xpra/avoid-x86-only-compile-flags.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 57c2d63..c896c62 100755
---- a/setup.py
-+++ b/setup.py
-@@ -1737,9 +1737,9 @@ membuffers_c = [memalign_c, buffers_c, xxhash_c]
- if modules_ENABLED:
- add_packages("xpra.buffers")
- buffers_pkgconfig = pkgconfig(optimize=3)
-- if BITS==32:
-- #this may well be sub-optimal:
-- add_to_keywords(buffers_pkgconfig, "extra_compile_args", "-mfpmath=387")
-+# if BITS==32:
-+# #this may well be sub-optimal:
-+# add_to_keywords(buffers_pkgconfig, "extra_compile_args", "-mfpmath=387")
- if cython_ENABLED:
- cython_add(Extension("xpra.buffers.membuf",
- ["xpra/buffers/membuf.pyx"]+membuffers_c, **buffers_pkgconfig))