aboutsummaryrefslogtreecommitdiffstats
path: root/community/yad
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 16:05:00 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2016-08-24 16:05:00 +0000
commit48e4e4128c7a60bb68d6d390338831ecc293c28c (patch)
tree09fa07ed2649e2ad2ce6e2182e4fd619e85352cd /community/yad
parent78d6fa519ae602e09cfa85aceb136e3af39673bf (diff)
downloadaports-48e4e4128c7a60bb68d6d390338831ecc293c28c.tar.bz2
aports-48e4e4128c7a60bb68d6d390338831ecc293c28c.tar.xz
community/yad: upgrade to 0.37.0, moved from testing
Diffstat (limited to 'community/yad')
-rw-r--r--community/yad/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/community/yad/APKBUILD b/community/yad/APKBUILD
new file mode 100644
index 0000000000..665ec20176
--- /dev/null
+++ b/community/yad/APKBUILD
@@ -0,0 +1,35 @@
+# Contributor: Francesco Colista <fcolista@alpinelinux.org>
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=yad
+pkgver=0.37.0
+pkgrel=0
+pkgdesc="A fork of zenity - display graphical dialogs from shell scripts or command line"
+url="http://sourceforge.net/projects/yad-dialog"
+arch="all"
+license="GPL3"
+depends="hicolor-icon-theme"
+depends_dev="gtk+2.0-dev intltool"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+source="http://sourceforge.net/projects/yad-dialog/files/$pkgname-$pkgver.tar.xz"
+builddir="$srcdir"/$pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --prefix=/usr \
+ --enable-icon-browser \
+ --disable-html
+ make || return 1
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="${pkgdir}" install
+ mkdir -p "$pkgdir/usr/share/doc/$pkgname"
+}
+
+md5sums="3a66cf4704c110d71bfcd6fcc227d5bd yad-0.37.0.tar.xz"
+sha256sums="91efaf24b56dfbed8e86e4af800f13ec9cca4b550b82b65552aaab40ebd3183a yad-0.37.0.tar.xz"
+sha512sums="8020aa194dbbf2f0e4613454b941c512a1712768d824fc1d5497856f58bdd07f88263bc09033242fe6d83909018157b962c6c013103ceaea7534286f61c1442c yad-0.37.0.tar.xz"