aboutsummaryrefslogtreecommitdiffstats
path: root/community/yubikey-manager-qt
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-03-01 23:44:19 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-03-02 10:46:03 +0100
commitd841e58042cd10f0928dbb6f99f510b68db2b782 (patch)
treefb6943c8b9be51e5b97708a90f13bcc2f3b0bf28 /community/yubikey-manager-qt
parent00bbbdf551e95283920376e76d15e19ebbc15ac2 (diff)
downloadaports-d841e58042cd10f0928dbb6f99f510b68db2b782.tar.bz2
aports-d841e58042cd10f0928dbb6f99f510b68db2b782.tar.xz
community/yubikey-manager-qt: move from testing
Diffstat (limited to 'community/yubikey-manager-qt')
-rw-r--r--community/yubikey-manager-qt/APKBUILD31
-rw-r--r--community/yubikey-manager-qt/use-py3.patch44
2 files changed, 75 insertions, 0 deletions
diff --git a/community/yubikey-manager-qt/APKBUILD b/community/yubikey-manager-qt/APKBUILD
new file mode 100644
index 0000000000..bea81b21e5
--- /dev/null
+++ b/community/yubikey-manager-qt/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=yubikey-manager-qt
+pkgver=1.1.4
+pkgrel=0
+pkgdesc="Cross-platform application for configuring any YubiKey over all USB transports"
+url="https://developers.yubico.com/yubikey-manager-qt/"
+arch="all !armhf" # armhf blocked by qt5-qtdeclarative
+license="BSD-2-Clause"
+depends="py3-ykman python3 py3-pyotherside qt5-qtquickcontrols
+ qt5-qtgraphicaleffects"
+makedepends="qt5-qtbase-dev qt5-qtdeclarative-dev qt5-qtquickcontrols2-dev"
+options="!check" # No test suite present
+source="https://github.com/Yubico/yubikey-manager-qt/archive/yubikey-manager-qt-$pkgver.tar.gz
+ use-py3.patch"
+builddir="$srcdir/$pkgname-$pkgname-$pkgver"
+
+build() {
+ qmake-qt5
+ make
+}
+
+package() {
+ make INSTALL_ROOT="$pkgdir" install
+ install -D -m0644 resources/ykman-gui.desktop "$pkgdir"/usr/share/applications/ykman-gui.desktop
+ install -D -m0644 resources/icons/ykman.png "$pkgdir"/usr/share/pixmaps/ykman.png
+}
+
+
+sha512sums="a13415a602e512d088d4a54aa10aa7e1770280b87cfc0fa12a90501dd0ed8265e400405d9f9d018398964f33abab640800bf3d0d6f88625dac9e416bf1a93ea4 yubikey-manager-qt-1.1.4.tar.gz
+d3c0c11032ac7dbfc8d48f08766d3d98061f7382008f7ee257ac2fe4150fc20b14c0003b59b9a642259365b105700d52b6b2ebf4343fb5dfa72125a36a9fe6fb use-py3.patch"
diff --git a/community/yubikey-manager-qt/use-py3.patch b/community/yubikey-manager-qt/use-py3.patch
new file mode 100644
index 0000000000..f8a7333e28
--- /dev/null
+++ b/community/yubikey-manager-qt/use-py3.patch
@@ -0,0 +1,44 @@
+diff --git a/ykman-cli/ykman-cli.pro b/ykman-cli/ykman-cli.pro
+index bd941d7..b6fbfbc 100644
+--- a/ykman-cli/ykman-cli.pro
++++ b/ykman-cli/ykman-cli.pro
+@@ -6,7 +6,7 @@ CONFIG -= app_bundle
+ TEMPLATE = app
+ SOURCES += main.cpp
+
+-buildqrc.commands = python ../build_qrc.py ${QMAKE_FILE_IN}
++buildqrc.commands = python3 ../build_qrc.py ${QMAKE_FILE_IN}
+ buildqrc.input = QRC_JSON
+ buildqrc.output = ${QMAKE_FILE_IN_BASE}.qrc
+ buildqrc.variable_out = RESOURCES
+@@ -14,7 +14,7 @@ QMAKE_STRIPFLAGS_LIB += --strip-unneeded
+ QMAKE_EXTRA_COMPILERS += buildqrc
+ QRC_JSON = resources.json
+ # Generate first time
+-system(python ../build_qrc.py resources.json)
++system(python3 ../build_qrc.py resources.json)
+
+ # Install python dependencies with pip for win and mac
+ mac|win32 {
+diff --git a/ykman-gui/ykman-gui.pro b/ykman-gui/ykman-gui.pro
+index f9772f5..b9c0df1 100644
+--- a/ykman-gui/ykman-gui.pro
++++ b/ykman-gui/ykman-gui.pro
+@@ -14,7 +14,7 @@ DEFINES += APP_VERSION=\\\"1.1.3\\\"
+
+ message(Version of this build: $$VERSION)
+
+-buildqrc.commands = python ../build_qrc.py ${QMAKE_FILE_IN}
++buildqrc.commands = python3 ../build_qrc.py ${QMAKE_FILE_IN}
+ buildqrc.input = QRC_JSON
+ buildqrc.output = ${QMAKE_FILE_IN_BASE}.qrc
+ buildqrc.variable_out = RESOURCES
+@@ -25,7 +25,7 @@ QMAKE_EXTRA_COMPILERS += buildqrc
+ QRC_JSON = resources.json
+
+ # Generate first time
+-system(python ../build_qrc.py resources.json)
++system(python3 ../build_qrc.py resources.json)
+
+ # Install python dependencies with pip on mac and win
+ win32|macx {