aboutsummaryrefslogtreecommitdiffstats
path: root/community/zathura
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-11-22 17:24:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-22 18:04:17 +0100
commit6ff0349ed565fb06454a531fc6b2334e434d2599 (patch)
tree98505672172b68cfde0147eb5cd2a54a5fd74e9e /community/zathura
parent55731fa14e9165e688e36e286ad17abdaf61cff2 (diff)
downloadaports-6ff0349ed565fb06454a531fc6b2334e434d2599.tar.bz2
aports-6ff0349ed565fb06454a531fc6b2334e434d2599.tar.xz
community/zathura: remove workaround for sphinx-build-3
Diffstat (limited to 'community/zathura')
-rw-r--r--community/zathura/APKBUILD10
-rw-r--r--community/zathura/doc-py3.patch11
2 files changed, 4 insertions, 17 deletions
diff --git a/community/zathura/APKBUILD b/community/zathura/APKBUILD
index 87ded266d1..7fefed8607 100644
--- a/community/zathura/APKBUILD
+++ b/community/zathura/APKBUILD
@@ -4,19 +4,18 @@
# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
pkgname=zathura
pkgver=0.4.4
-pkgrel=0
+pkgrel=1
pkgdesc="zathura - highly customizable and functional document viewer"
url="https://git.pwmt.org/pwmt/zathura"
arch="all"
license="Zlib"
depends="libmagic"
makedepends="girara-dev file-dev sqlite-dev intltool check-dev libseccomp-dev
- py3-docutils ncurses meson ninja py3-sphinx desktop-file-utils"
+ py3-docutils ncurses meson ninja py3-sphinx desktop-file-utils appstream-glib"
checkdepends="mesa-dri-swrast dbus xvfb"
subpackages="$pkgname-doc $pkgname-dev $pkgname-lang"
-source="https://git.pwmt.org/pwmt/$pkgname/-/archive/$pkgver/$pkgname-$pkgver.tar.gz
+source="https://git.pwmt.org/pwmt/zathura/-/archive/$pkgver/zathura-$pkgver.tar.gz
test.sh
- doc-py3.patch
"
build() {
@@ -33,5 +32,4 @@ package() {
}
sha512sums="8d1e5969cc2f9502d7d966d3341c8f7437422f2dcf952bc2567a5061e611c6fe90c2bc6670963d81b608aa621d70f77ec513d6ab9f03304894bd9ac648aaa6e7 zathura-0.4.4.tar.gz
-2190d324753810c8dc5b109274dcf4f644e51edcda876c225ac76369dd569dda0b8db445b01dac1ac2b06178534d18e1074ca37d1a69622bdc58fd77350b4ddd test.sh
-7956eb2d925e1cd415846dc8116399a34af7fcb14aa6573b3328893f57b845cda91dc2e709d0b4a23b3c808dda946b48d7eb8d2a68d0fb2eb965556ff0f90702 doc-py3.patch"
+2190d324753810c8dc5b109274dcf4f644e51edcda876c225ac76369dd569dda0b8db445b01dac1ac2b06178534d18e1074ca37d1a69622bdc58fd77350b4ddd test.sh"
diff --git a/community/zathura/doc-py3.patch b/community/zathura/doc-py3.patch
deleted file mode 100644
index b9bc5a96f1..0000000000
--- a/community/zathura/doc-py3.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/doc/meson.build b/doc/meson.build
-index d178322..4e8ee7c 100644
---- a/doc/meson.build
-+++ b/doc/meson.build
-@@ -1,4 +1,4 @@
--sphinx = find_program('sphinx-build', required: get_option('manpages'))
-+sphinx = find_program('sphinx-build-3', required: get_option('manpages'))
- if sphinx.found()
- custom_target('man pages',
- command: [
-