aboutsummaryrefslogtreecommitdiffstats
path: root/community/zutils
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-13 08:47:38 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-13 08:47:41 +0000
commit3da278694fd58fe0304850fbc463df5a6a58901d (patch)
tree6408989375c6c9fd7944caf79afc0496fa6ba109 /community/zutils
parentfa1aa6b8e0c99b22eb56812e34b786f0de51cf86 (diff)
downloadaports-3da278694fd58fe0304850fbc463df5a6a58901d.tar.bz2
aports-3da278694fd58fe0304850fbc463df5a6a58901d.tar.xz
testing/zutils: move to community
Diffstat (limited to 'community/zutils')
-rw-r--r--community/zutils/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/community/zutils/APKBUILD b/community/zutils/APKBUILD
new file mode 100644
index 0000000000..8ff0055985
--- /dev/null
+++ b/community/zutils/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=zutils
+pkgver=1.7
+pkgrel=0
+pkgdesc="A collection of utilities able to process any combination of compressed and uncompressed files transparently"
+url="http://www.nongnu.org/zutils/zutils.html"
+arch="all"
+license="GPL-2.0"
+subpackages="$pkgname-doc"
+checkdepends="bzip2"
+source="http://download.savannah.gnu.org/releases/$pkgname/$pkgname-$pkgver.tar.lz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="eaf49d9aefb21460635eb6d0f1ae49ddc51b5a4e5d6d0943637194351ef910471203908d6bfe93ad37ca62ceacebe5b208d12b4bb8dda68cd9dbcdb7c7f848e1 zutils-1.7.tar.lz"