aboutsummaryrefslogtreecommitdiffstats
path: root/community/zziplib
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2017-07-15 23:08:58 +0200
committerTimo Teräs <timo.teras@iki.fi>2017-07-18 07:34:23 +0000
commit2a03ef848dd1a80476bbc66a83fab82c05153deb (patch)
treee160bbd1f275f011c9e7af4650dbed09b417c4af /community/zziplib
parenta33c270c6ab8ac63f4e0fe22bfff6c0be4474e4a (diff)
downloadaports-2a03ef848dd1a80476bbc66a83fab82c05153deb.tar.bz2
aports-2a03ef848dd1a80476bbc66a83fab82c05153deb.tar.xz
community/zziplib: upgrade to 0.13.66
* Modernize abuild * Add patch from opensuse
Diffstat (limited to 'community/zziplib')
-rw-r--r--community/zziplib/APKBUILD23
-rw-r--r--community/zziplib/CVE-2017-5979.patch13
2 files changed, 22 insertions, 14 deletions
diff --git a/community/zziplib/APKBUILD b/community/zziplib/APKBUILD
index 86e631baa7..b452e88e20 100644
--- a/community/zziplib/APKBUILD
+++ b/community/zziplib/APKBUILD
@@ -1,21 +1,19 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
pkgname=zziplib
-pkgver=0.13.62
-pkgrel=3
+pkgver=0.13.66
+pkgrel=0
pkgdesc="Lightweight library to easily extract data from zip files"
url="http://zziplib.sourceforge.net"
arch="all"
license="LGPL2+ MPL-1.1"
-depends=""
-depends_dev="zlib-dev"
-makedepends="$depends_dev perl python2"
+makedepends="zlib-dev python2 xmlto"
subpackages="$pkgname-dev $pkgname-doc $pkgname-utils"
-source="http://downloads.sourceforge.net/zziplib/$pkgname-$pkgver.tar.bz2"
+source="https://sourceforge.net/projects/zziplib/files/zziplib13/$pkgver/$pkgname-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
update_config_guess
}
@@ -23,14 +21,13 @@ build() {
cd "$builddir"
./configure \
--prefix=/usr \
- --disable-static \
- || return 1
- make || return 1
+ --disable-static
+ make
}
package() {
cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
}
utils() {
@@ -39,6 +36,4 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-md5sums="5fe874946390f939ee8f4abe9624b96c zziplib-0.13.62.tar.bz2"
-sha256sums="a1b8033f1a1fd6385f4820b01ee32d8eca818409235d22caf5119e0078c7525b zziplib-0.13.62.tar.bz2"
-sha512sums="fd3b9e9015ba7603bdebd8f6a2ac6d11003705bfab22f3a0025f75455042664aea69440845b59e6f389417dff5ac777f49541d8cbacb2a220e67d20bb6973e25 zziplib-0.13.62.tar.bz2"
+sha512sums="893885d85293269fd8ff14d61eaae5f7d07689a16dd9c07c1ae8d46ea2b2f94a13d6aab19670efa7716cafe5e9f8efb1cbc1254bd9e860c836faa35736bdbe20 zziplib-0.13.66.tar.gz"
diff --git a/community/zziplib/CVE-2017-5979.patch b/community/zziplib/CVE-2017-5979.patch
new file mode 100644
index 0000000000..6aaf8ed66d
--- /dev/null
+++ b/community/zziplib/CVE-2017-5979.patch
@@ -0,0 +1,13 @@
+Index: zziplib-0.13.62/zzip/fseeko.c
+===================================================================
+--- zziplib-0.13.62.orig/zzip/fseeko.c
++++ zziplib-0.13.62/zzip/fseeko.c
+@@ -255,7 +255,7 @@ zzip_entry_findfirst(FILE * disk)
+ return 0;
+ /* we read out chunks of 8 KiB in the hope to match disk granularity */
+ ___ zzip_off_t pagesize = PAGESIZE; /* getpagesize() */
+- ___ ZZIP_ENTRY *entry = malloc(sizeof(*entry));
++ ___ ZZIP_ENTRY *entry = calloc(1, sizeof(*entry));
+ if (! entry)
+ return 0;
+ ___ unsigned char *buffer = malloc(pagesize);