aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-24 19:07:10 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-24 23:47:47 -0300
commit000205e25075e0b18089116ace98d1d6361853bb (patch)
treee09fee020b7205040ed99e961b75f50d00b7857c /community
parent2f60a33da02ddfa9383bf7fe50d0e9e604acca2f (diff)
downloadaports-000205e25075e0b18089116ace98d1d6361853bb.tar.bz2
aports-000205e25075e0b18089116ace98d1d6361853bb.tar.xz
community/xset: move from main
Diffstat (limited to 'community')
-rw-r--r--community/xset/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/community/xset/APKBUILD b/community/xset/APKBUILD
new file mode 100644
index 0000000000..68bcbef773
--- /dev/null
+++ b/community/xset/APKBUILD
@@ -0,0 +1,36 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=xset
+pkgver=1.2.4
+pkgrel=0
+pkgdesc="X.Org xset application"
+url="http://xorg.freedesktop.org"
+arch="all"
+license="MIT"
+subpackages="$pkgname-doc"
+depends=""
+makedepends="libxmu-dev libx11-dev libxext-dev util-macros"
+source="https://www.x.org/releases/individual/app/$pkgname-$pkgver.tar.bz2"
+
+build() {
+ cd "$builddir"
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var
+ make
+}
+
+check() {
+ make -C "$builddir" check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="f24714c9a82081a09d3054bbad98553de9366992f22eaf3e2bcadbb58fad1d3dad2547fef6fa9898d8a9df064573c29df9d82a5c801fa92248604c95f65dc83d xset-1.2.4.tar.bz2"