aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-10-17 13:29:40 +0200
committerKevin Daudt <kdaudt@alpinelinux.org>2019-10-24 18:56:34 +0000
commit03ace6b304e0b5ee59999e0fcb518503c6a41c72 (patch)
treeb14be8d4a6cb2df0fdb62e62089efdd13498b106 /community
parentb47f08f14b0ae8a006cf048fd22156b562b97245 (diff)
downloadaports-03ace6b304e0b5ee59999e0fcb518503c6a41c72.tar.bz2
aports-03ace6b304e0b5ee59999e0fcb518503c6a41c72.tar.xz
community/goffice: disable on s390x due to librsvg
Closes !509
Diffstat (limited to 'community')
-rw-r--r--community/goffice/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/community/goffice/APKBUILD b/community/goffice/APKBUILD
index 65b342b20f..49b643a778 100644
--- a/community/goffice/APKBUILD
+++ b/community/goffice/APKBUILD
@@ -3,17 +3,17 @@ pkgname=goffice
pkgver=0.10.45
pkgrel=0
_maj=${pkgver%%.*}
-_min=${pkgver#${_maj}.}
+_min=${pkgver#$_maj.}
_min=${_min%%.*}
pkgdesc="Library of document-centric objects and utilities built on top of GLib and Gtk+"
url="http://www.gnome.org"
-arch="all"
+arch="all !s390x"
license="GPL-2.0-or-later OR GPL-3.0-or-later"
makedepends="librsvg-dev intltool gtk+-dev autoconf automake libtool gtk-doc
libxslt-dev gobject-introspection-dev glib-dev libgsf-dev cairo-dev
libxml2-dev gtk+3.0-dev"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-source="https://download.gnome.org/sources/$pkgname/$_maj.$_min/$pkgname-$pkgver.tar.xz
+source="https://download.gnome.org/sources/goffice/$_maj.$_min/goffice-$pkgver.tar.xz
testsuite-workaround.patch
"
prepare() {
@@ -23,7 +23,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -36,12 +35,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}