aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2019-01-19 23:47:48 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2019-01-20 00:47:44 +0100
commit1000910860bd5281fcc9696cd34bc6bc80113b1c (patch)
tree1a39fad6838f4f55dc2a9b7c994d780713d50714 /community
parent4e88e935ba0b6e51178c6a341c8796af61cc9f22 (diff)
downloadaports-1000910860bd5281fcc9696cd34bc6bc80113b1c.tar.bz2
aports-1000910860bd5281fcc9696cd34bc6bc80113b1c.tar.xz
community/snapcast: fix OpenRC service
Without creating /var/lib/snapserver the services fails to start with the following error message: Exception: failed to create settings directory: "/var/lib/snapserver/": 13 Because the snapcast process itself tries to create the directory but doesn't run as root and therefore gets an EACCESS (13) error. While at it I also specified the pidfile created by the snapcast process. No idea how OpenRC was even able to track the service status without it.
Diffstat (limited to 'community')
-rw-r--r--community/snapcast/APKBUILD4
-rw-r--r--community/snapcast/snapcast-server.initd3
2 files changed, 4 insertions, 3 deletions
diff --git a/community/snapcast/APKBUILD b/community/snapcast/APKBUILD
index babcf72142..23f0499a41 100644
--- a/community/snapcast/APKBUILD
+++ b/community/snapcast/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=snapcast
pkgver=0.15.0
-pkgrel=3
+pkgrel=4
pkgdesc="Synchronous multi-room audio player"
url="https://github.com/badaix/snapcast"
arch="all"
@@ -71,5 +71,5 @@ sha512sums="3751eeaa9be4ffd5c7633b8770f36e87360ab83004f090a8350e377f60a79d9502b9
85792a3edf8de76228d8114992f6fdfba6321aeca29d1f773038e88b96e1d6cdf9b6e3993eb09da934c8f561977827cb57f4b435c99405e5a2b4645edd2b5bd2 respect-optimization-level.patch
833ce6a5fecb023f32df340df98b5cfbecc765735d7133228dd703a6a0c7f2b67ac95aa787ac7119a2eb87e768e5c4deb12738d0b0354db3510d9047f9e9b24f snapcast-client.initd
fa353d7974d3a8b3b22ff009b762c7c4ee318f9f83e22762a9ebf550484b9fc3cc4dffd389b6d756630dc035cb86d5c5643541957785f8bbf71fe4915691c337 snapcast-client.confd
-6d6b6ea52ecb13c74f1cc6aa777ee2c1c00c9f67c3383fede6b1ad6af522bc24b5a0684939e78c5e2af6f2f35259c7c536f04b63244098f561d0590a93a7ab9f snapcast-server.initd
+ff610e08274d317e0df9590de47f3425d23a38528f82b9998de04d73cf2167ddb6aad237ddce9864b6c36fff959afb6a892c554ce40fd3e3d62c1308b022b2bb snapcast-server.initd
48d494143d044a413b414b32cd8be51d4242234b6d7cb03102914a42b1ea6b1913c2c31b223c23c6be316918e731875149a2505daa03165659d0a1be3ca7e75c snapcast-server.confd"
diff --git a/community/snapcast/snapcast-server.initd b/community/snapcast/snapcast-server.initd
index ae336d36cf..2e6d9a9b67 100644
--- a/community/snapcast/snapcast-server.initd
+++ b/community/snapcast/snapcast-server.initd
@@ -5,6 +5,7 @@ command="/usr/bin/snapserver"
command_args="-d $snapserver_opts"
command_user="snapcast"
start_stop_daemon_args="--quiet"
+pidfile="/run/snapserver/pid"
depend() {
need net
@@ -13,6 +14,6 @@ depend() {
start_pre() {
checkpath --directory --owner snapcast:audio --mode 0775 \
- /run/snapserver
+ /run/snapserver /var/lib/snapserver
}