aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-01 12:20:00 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-01 12:20:00 -0300
commit1137b2928ff936e972e11ce8a44e0472dea997b2 (patch)
treefa54f325518c303124bec6c41fa226f5a3e4d5e5 /community
parentf2c9c39a171ba841275d3c53a5c72837c6df1c70 (diff)
downloadaports-1137b2928ff936e972e11ce8a44e0472dea997b2.tar.bz2
aports-1137b2928ff936e972e11ce8a44e0472dea997b2.tar.xz
community/alien: upgrade to 8.95.1
Diffstat (limited to 'community')
-rw-r--r--community/alien/APKBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/community/alien/APKBUILD b/community/alien/APKBUILD
index 046e68086d..e75fb9cc50 100644
--- a/community/alien/APKBUILD
+++ b/community/alien/APKBUILD
@@ -1,29 +1,23 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=alien
-pkgver=8.95
+pkgver=8.95.1
pkgrel=0
pkgdesc="Alien is a program that converts between the rpm, dpkg, stampede slp, and slackware tgz file formats"
url="http://joeyh.name/code/alien"
arch="noarch"
-license="GPL-2.0"
+license="GPL-2.0-only"
depends="perl"
-depends_dev=""
-makedepends="$depends_dev"
-install=""
subpackages="$pkgname-doc"
-source="http://ftp.de.debian.org/debian/pool/main/a/$pkgname/${pkgname}_$pkgver.tar.xz"
+source="http://ftp.de.debian.org/debian/pool/main/a/alien/alien_$pkgver.tar.xz"
-builddir="${srcdir}"/${pkgname}-${pkgver}
build() {
- cd "$builddir"
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="c46d3c82542dc3d96eeabea0f0c7ab5b572acaf67d15e2064ea01df32d69a2cf6e083754be49269df6cd7431ec5b3e09ddcb83fbe2ee17843b22e9cd3e73073c alien_8.95.tar.xz"
+sha512sums="e57c22ba4c022f03272c535fae709981333ee1357b7ee84f40611f632c7c31e2418cbbafff0bd951e896ee2784a42f9ee040eb2286c24a82273108bc5352f5d6 alien_8.95.1.tar.xz"