aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-12-08 15:25:55 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-12-08 15:28:45 +0100
commit115b71647f4bd35aeceac03919796ef5a33664a7 (patch)
treef2b849f1364cc6677c63527b254c921a058fa1ca /community
parent28204787281d64fb77ce3bbfebba6febb15860a2 (diff)
downloadaports-115b71647f4bd35aeceac03919796ef5a33664a7.tar.bz2
aports-115b71647f4bd35aeceac03919796ef5a33664a7.tar.xz
community/kea-hook-runscript: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/kea-hook-runscript/APKBUILD22
1 files changed, 22 insertions, 0 deletions
diff --git a/community/kea-hook-runscript/APKBUILD b/community/kea-hook-runscript/APKBUILD
new file mode 100644
index 0000000000..9b88458c62
--- /dev/null
+++ b/community/kea-hook-runscript/APKBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Steve Holweg <skytep@gmail.com>
+pkgname=kea-hook-runscript
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="This a hook for the Kea DHCP server that allows to run an external script."
+arch="all !armhf !armv7" # limited by kea
+url="https://github.com/zorun/kea-hook-runscript"
+license="MPL2"
+depends="kea-common>=1.4.0"
+makedepends="boost-dev kea-dev"
+source="https://github.com/zorun/kea-hook-runscript/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
+options="!check" # Library and makefile provide no tests
+
+build() {
+ make
+}
+
+package() {
+ install -Dm755 kea-hook-runscript.so "$pkgdir"/usr/lib/hooks/kea-hook-runscript.so
+}
+
+sha512sums="048610f9c4388a9f00e550c139d2c90cd347ae516bc92e0d10082bf1c42ceb2be6857399919c36fe09faba67e3b6e8bd0bac09cf35e8899faafd5872fb276293 kea-hook-runscript-1.3.1.tar.gz"