aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-11-28 21:54:40 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-12-01 19:18:29 +0000
commit1ea7a73d579bd5393563370abe1683f5782bae57 (patch)
treec8e78c795c77f9c3dbad727e15a5bb0bdfd1b921 /community
parentb6ce3b6d3ba13e894f7b76d21ce320f24a2ea7ab (diff)
downloadaports-1ea7a73d579bd5393563370abe1683f5782bae57.tar.bz2
aports-1ea7a73d579bd5393563370abe1683f5782bae57.tar.xz
community/vault: disable ui
The ui [requires nodejs 10][0], while nodejs 12 is in the repositories. To make vault still build, disable the UI for now. [0]:https://github.com/hashicorp/vault/issues/7232
Diffstat (limited to 'community')
-rw-r--r--community/vault/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/community/vault/APKBUILD b/community/vault/APKBUILD
index b82911e5a6..f52ca6885d 100644
--- a/community/vault/APKBUILD
+++ b/community/vault/APKBUILD
@@ -7,7 +7,7 @@ pkgdesc="Vault is a tool for securely accessing secrets"
url="https://www.vaultproject.io/"
arch="all !s390x"
license="MPL-2.0"
-makedepends="libcap bash make go python2 yarn npm go-bindata-assetfs"
+makedepends="libcap bash make go python2 go-bindata-assetfs"
install="$pkgname.pre-install"
pkgusers="vault"
pkggroups="vault"
@@ -20,10 +20,9 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/hashicorp/$pkgname/archive/v
vault.initd"
build() {
- CGO_ENABLED=0 make static-dist prep
+ CGO_ENABLED=0 make prep
CGO_ENABLED=0 go build -v -o bin/$pkgname \
- -ldflags "-X github.com/hashicorp/vault/version.GitDescribe='$pkgver'" \
- --tags ui
+ -ldflags "-X github.com/hashicorp/vault/version.GitDescribe='$pkgver'"
}
package() {