aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorThomas Liske <thomas@fiasko-nw.net>2020-05-02 11:15:27 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-05-02 21:16:04 +0000
commit20e46493f1201c44415b9350ed51fef18af59fac (patch)
tree59b1de95a242a3239bac382547070749de10e255 /community
parent956430bfea87309cf67942c9391c426279814e7e (diff)
downloadaports-20e46493f1201c44415b9350ed51fef18af59fac.tar.bz2
aports-20e46493f1201c44415b9350ed51fef18af59fac.tar.xz
community/py3-pyroute2: move from testing
Diffstat (limited to 'community')
-rw-r--r--community/py3-pyroute2/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-pyroute2/APKBUILD b/community/py3-pyroute2/APKBUILD
new file mode 100644
index 0000000000..84f7bbfba1
--- /dev/null
+++ b/community/py3-pyroute2/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Thomas Liske <thomas@fiasko-nw.net>
+pkgname=py3-pyroute2
+_pkgname=pyroute2
+pkgver=0.5.11
+pkgrel=0
+pkgdesc="Python Netlink library"
+url="https://github.com/svinota/pyroute2"
+arch="noarch"
+license="GPL-2.0-or-later OR Apache-2.0"
+makedepends="py3-setuptools py3-pytest"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+check() {
+ pytest
+}
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ # do not ship cli scripts for now
+ rm -rf "${pkgdir:?}/usr/bin"
+}
+
+sha512sums="38159cb3467711a73742c75154828563681df79dedba040a49fadc11afda5bbae756f724d89905fb24c7ce0d4fa0a6107aac9750586286a15eeffaaa8fa3d6bc pyroute2-0.5.11.tar.gz"