aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJoe Searle <joe@jsearle.net>2019-09-21 16:51:34 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-11-03 00:53:38 -0300
commit2515332fb393ab55c255b5a8cd10cbe4ee4c2188 (patch)
treebe9a8ddac3a37c95efadb88a2e1ca8fbceffd254 /community
parentf4f65d2474d5602153754d2f2dbd19807031e89e (diff)
downloadaports-2515332fb393ab55c255b5a8cd10cbe4ee4c2188.tar.bz2
aports-2515332fb393ab55c255b5a8cd10cbe4ee4c2188.tar.xz
community/sngrep: fix linting issues and license
Diffstat (limited to 'community')
-rw-r--r--community/sngrep/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/community/sngrep/APKBUILD b/community/sngrep/APKBUILD
index 08fb8a8a45..e1063d1161 100644
--- a/community/sngrep/APKBUILD
+++ b/community/sngrep/APKBUILD
@@ -2,27 +2,24 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=sngrep
pkgver=1.4.6
-pkgrel=0
+pkgrel=1
pkgdesc="A tool for displaying SIP call message flows from a terminal"
url="https://github.com/irontec/sngrep"
arch="all !ppc64le"
-license="GPL-3.0"
+license="GPL-3.0-or-later"
depends="sed"
-makedepends="autoconf automake ncurses-dev libpcap-dev
+makedepends="autoconf automake ncurses-dev libpcap-dev
pcre-dev libgcrypt-dev openssl-dev"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.zip::https://github.com/irontec/$pkgname/archive/v$pkgver.zip
+source="$pkgname-$pkgver.zip::https://github.com/irontec/sngrep/archive/v$pkgver.zip
stdin-reopen-musl.patch"
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare
- cd "$builddir"
./bootstrap.sh
}
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--with-openssl \
@@ -33,12 +30,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir/" install
}